<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
    <title>Power Trip delivers thrash metal justice on “Nightmare Logic” | The Campus Ledger</title>
    <meta charset="UTF-8" />
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="http://blogs.jccc.edu/campusledger/xmlrpc.php" />
    <meta property="og:image" content="http://blogs.jccc.edu/campusledger/files/2017/02/ptriponline.png" /><meta name="author" content="arhodes2">
<link rel="icon" type="image/png" href="http://blogs.jccc.edu/campusledger/files/2016/03/LedgerLogoSpring16Vectors-03.jpg"><link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Campus Ledger &raquo; Feed" href="http://blogs.jccc.edu/campusledger/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Campus Ledger &raquo; Comments Feed" href="http://blogs.jccc.edu/campusledger/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Campus Ledger &raquo; Power Trip delivers thrash metal justice on “Nightmare Logic” Comments Feed" href="http://blogs.jccc.edu/campusledger/2017/02/08/power-trip-delivers-thrash-metal-justice-on-nightmare-logic/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/blogs.jccc.edu\/campusledger\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.2"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='colorbox-theme1-css'  href='http://blogs.jccc.edu/campusledger/wp-content/plugins/jquery-lightbox-for-native-galleries/colorbox/theme1/colorbox.css?ver=1.3.14' type='text/css' media='screen' />
<link rel='stylesheet' id='awesome-weather-css'  href='http://blogs.jccc.edu/campusledger/wp-content/plugins/awesome-weather/awesome-weather.css?ver=4.7.2' type='text/css' media='all' />
<style id='awesome-weather-inline-css' type='text/css'>
.awesome-weather-wrap { font-family: 'Open Sans', sans-serif;  font-weight: 400; font-size: 14px; line-height: 14px; } 
</style>
<link rel='stylesheet' id='opensans-googlefont-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C300&#038;ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='http://blogs.jccc.edu/campusledger/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='google_font_open_sans-css'  href='http://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C400%2C600%2C700&#038;ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='google_font_roboto-css'  href='http://fonts.googleapis.com/css?family=Roboto%3A500%2C400italic%2C700%2C500italic%2C400%2C300&#038;ver=4.7.2' type='text/css' media='all' />
<!-- Inline jetpack_facebook_likebox -->
<style id='jetpack_facebook_likebox-inline-css' type='text/css'>
.widget_facebook_likebox {
	overflow: hidden;
}

</style>
<link rel='stylesheet' id='ms-main-css'  href='http://blogs.jccc.edu/campusledger/wp-content/plugins/masterslider/public/assets/css/masterslider.main.css?ver=2.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='ms-custom-css'  href='http://blogs.jccc.edu/campusledger/wp-content/plugins/masterslider/assets/custom.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='js_composer_front-css'  href='http://blogs.jccc.edu/campusledger/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=4.9' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='http://blogs.jccc.edu/campusledger/wp-content/themes/Newspaper/style.css?ver=6.6.4' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='http://blogs.jccc.edu/campusledger/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://blogs.jccc.edu/campusledger/wp-content/plugins/jetpack/css/jetpack.css?ver=4.6' type='text/css' media='all' />
<script type='text/javascript' src='http://blogs.jccc.edu/campusledger/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://blogs.jccc.edu/campusledger/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://blogs.jccc.edu/campusledger/wp-content/plugins/jquery-lightbox-for-native-galleries/colorbox/jquery.colorbox-min.js?ver=1.3.14'></script>
<script type='text/javascript' src='http://blogs.jccc.edu/campusledger/wp-content/plugins/wpms-global-content/assets/js/script.js?ver=4.7.2'></script>
<link rel='https://api.w.org/' href='http://blogs.jccc.edu/campusledger/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://blogs.jccc.edu/campusledger/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://blogs.jccc.edu/campusledger/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='JCAV-TV Video Roundup: Super Bowl Predictions, Student Concert Series Auditions' href='http://blogs.jccc.edu/campusledger/2017/02/03/jcav-tv-video-roundup-super-bowl-predictions-student-concert-series-auditions/' />
<link rel='next' title='Experience, leadership help keep team members eye on the ball' href='http://blogs.jccc.edu/campusledger/2017/02/09/experience-leadership-help-keep-team-members-eye-on-the-ball/' />
<meta name="generator" content="WordPress 4.7.2" />
<link rel="canonical" href="http://blogs.jccc.edu/campusledger/2017/02/08/power-trip-delivers-thrash-metal-justice-on-nightmare-logic/" />
<link rel='shortlink' href='http://wp.me/p1Mws0-2Jg' />
<link rel="alternate" type="application/json+oembed" href="http://blogs.jccc.edu/campusledger/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fblogs.jccc.edu%2Fcampusledger%2F2017%2F02%2F08%2Fpower-trip-delivers-thrash-metal-justice-on-nightmare-logic%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://blogs.jccc.edu/campusledger/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fblogs.jccc.edu%2Fcampusledger%2F2017%2F02%2F08%2Fpower-trip-delivers-thrash-metal-justice-on-nightmare-logic%2F&#038;format=xml" />
				<script type="text/javascript">
				var _gaq = _gaq || [];
								_gaq.push(['_setAccount', 'UA-395939-1']);
										_gaq.push(['_setDomainName', 'jccc.edu']);
										_gaq.push(['_trackPageview']);
					
									(function() {
					var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
					ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
					var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
				  })();
				</script>			
				
<link rel='dns-prefetch' href='//v0.wordpress.com'>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'>
<link rel='dns-prefetch' href='//s0.wp.com'>
<link rel='dns-prefetch' href='//s1.wp.com'>
<link rel='dns-prefetch' href='//s2.wp.com'>
<link rel='dns-prefetch' href='//public-api.wordpress.com'>
<link rel='dns-prefetch' href='//0.gravatar.com'>
<link rel='dns-prefetch' href='//1.gravatar.com'>
<link rel='dns-prefetch' href='//2.gravatar.com'>
<!--[if lt IE 9]><script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <!-- jQuery Lightbox For Native Galleries v3.2.2 | http://www.viper007bond.com/wordpress-plugins/jquery-lightbox-for-native-galleries/ -->
<script type="text/javascript">
// <![CDATA[
	jQuery(document).ready(function($){
		$(".gallery").each(function(index, obj){
			var galleryid = Math.floor(Math.random()*10000);
			$(obj).find("a").colorbox({rel:galleryid, maxWidth:"95%", maxHeight:"95%"});
		});
		$("a.lightbox").colorbox({maxWidth:"95%", maxHeight:"95%"});
	});
// ]]>
</script>
<meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="http://blogs.jccc.edu/campusledger/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="http://blogs.jccc.edu/campusledger/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]-->
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Power Trip delivers thrash metal justice on “Nightmare Logic”" />
<meta property="og:url" content="http://blogs.jccc.edu/campusledger/2017/02/08/power-trip-delivers-thrash-metal-justice-on-nightmare-logic/" />
<meta property="og:description" content="Aaron Rhodes Editor-in-chief arhodes2@jccc.edu Power Trip is five-piece crossover thrash metal band from Dallas, Texas. Since its formation in 2008, the group has released several tapes and EPs, as…" />
<meta property="article:published_time" content="2017-02-08T16:59:49+00:00" />
<meta property="article:modified_time" content="2017-02-08T17:00:25+00:00" />
<meta property="og:site_name" content="The Campus Ledger" />
<meta property="og:image" content="http://blogs.jccc.edu/campusledger/files/2017/02/ptriponline.png" />
<meta property="og:image:width" content="682" />
<meta property="og:image:height" content="450" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:image" content="http://blogs.jccc.edu/campusledger/files/2017/02/ptriponline.png?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<!-- JS generated by theme -->

<script>
    

var tdBlocksArray = []; //here we store all the items for the current page

//td_block class - each ajax block uses a object of this class for requests
function tdBlock() {
    this.id = '';
    this.block_type = 1; //block type id (1-234 etc)
    this.atts = '';
    this.td_column_number = '';
    this.td_current_page = 1; //
    this.post_count = 0; //from wp
    this.found_posts = 0; //from wp
    this.max_num_pages = 0; //from wp
    this.td_filter_value = ''; //current live filter value
    this.is_ajax_running = false;
    this.td_user_action = ''; // load more or infinite loader (used by the animation)
    this.header_color = '';
    this.ajax_pagination_infinite_stop = ''; //show load more at page x
}

    
    
        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

            if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var tds_smooth_scroll=true;
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var td_ajax_url="https:\/\/blogs.jccc.edu\/campusledger\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=6.6.4";
var td_get_template_directory_uri="http:\/\/blogs.jccc.edu\/campusledger\/wp-content\/themes\/Newspaper";
var tds_snap_menu="smart_snap_mobile";
var tds_logo_on_sticky="";
var tds_header_style="10";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#4db2ec";
var tds_smart_sidebar="";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>

<link rel="icon" href="http://blogs.jccc.edu/campusledger/files/2016/03/cropped-LedgerLogoSpring16Vectors-03-32x32.jpg" sizes="32x32" />
<link rel="icon" href="http://blogs.jccc.edu/campusledger/files/2016/03/cropped-LedgerLogoSpring16Vectors-03-192x192.jpg" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="http://blogs.jccc.edu/campusledger/files/2016/03/cropped-LedgerLogoSpring16Vectors-03-180x180.jpg" />
<meta name="msapplication-TileImage" content="http://blogs.jccc.edu/campusledger/files/2016/03/cropped-LedgerLogoSpring16Vectors-03-270x270.jpg" />
<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head>

<body class="post-template-default single single-post postid-10494 single-format-standard power-trip-delivers-thrash-metal-justice-on-nightmare-logic wpb-js-composer js-comp-ver-4.9 vc_responsive td-full-layout" itemscope="itemscope" itemtype="http://schema.org/WebPage">


<div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>

<div id="td-outer-wrap">

    <div class="td-transition-content-and-menu td-mobile-nav-wrap">
        <div id="td-mobile-nav">
    <!-- mobile menu close -->
    <div class="td-mobile-close">
        <a href="#">CLOSE</a>
        <div class="td-nav-triangle"></div>
    </div>

    <div class="td-mobile-content">
        <div class="menu-main-nav-container"><ul id="menu-main-nav" class=""><li id="menu-item-4884" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first menu-item-4884"><a href="http://blogs.jccc.edu/campusledger/news/">News</a></li>
<li id="menu-item-4885" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4885"><a href="http://blogs.jccc.edu/campusledger/features/">Features</a></li>
<li id="menu-item-8920" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8920"><a href="http://blogs.jccc.edu/campusledger/entertainment/">Entertainment</a></li>
<li id="menu-item-4888" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-4888"><a href="http://blogs.jccc.edu/campusledger/sports-2/">Sports</a>
<ul class="sub-menu">
	<li id="menu-item-0" class="menu-item-0"><a href="http://blogs.jccc.edu/campusledger/category/sports/sportsreport/">Cavalier Sports Report</a></li>
</ul>
</li>
<li id="menu-item-4887" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-4887"><a href="http://blogs.jccc.edu/campusledger/opinion/">Opinion</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a href="http://blogs.jccc.edu/campusledger/category/opinion/letter-to-the-editor/">Letter to the Editor</a></li>
</ul>
</li>
<li id="menu-item-4890" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4890"><a href="http://blogs.jccc.edu/campusledger/multimedia/">JCAV-TV</a></li>
<li id="menu-item-8715" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8715"><a href="http://blogs.jccc.edu/ecavradio/">ECAV Radio</a></li>
</ul></div>    </div>
</div>    </div>

        <div class="td-transition-content-and-menu td-content-wrap">



<!--
Header style 10
-->

<div class="td-header-wrap td-header-style-10">

	<div class="td-header-top-menu-full">
		<div class="td-container td-header-row td-header-top-menu">
            
    <div class="top-bar-style-1">
        
<div class="td-header-sp-top-menu">


	<div class="td_data_time">Friday, February 10, 2017</div></div>
        <div class="td-header-sp-top-widget">
    <span class="td-social-icon-wrap"><a target="_blank" href="https://www.facebook.com/CampusLedger/" title="Facebook"><i class="td-icon-font td-icon-facebook"></i></a></span><span class="td-social-icon-wrap"><a target="_blank" href="http://www.twitter.com/campusledger" title="Twitter"><i class="td-icon-font td-icon-twitter"></i></a></span><span class="td-social-icon-wrap"><a target="_blank" href="https://www.youtube.com/user/jcccjcavtv" title="Youtube"><i class="td-icon-font td-icon-youtube"></i></a></span></div>
    </div>

		</div>
	</div>

    <div class="td-banner-wrap-full td-logo-wrap-full">
        <div class="td-header-sp-logo">
            	<a href="http://blogs.jccc.edu/campusledger/">
		<img class="td-retina-data td-logo"  data-retina="http://blogs.jccc.edu/campusledger/files/2016/09/LedgerBannerSpring16-retina-300x99.png" src="http://blogs.jccc.edu/campusledger/files/2016/09/LedgerBannerSpring16.png" alt=""/>
	</a>
        </div>
    </div>

	<div class="td-header-menu-wrap-full">
		<div class="td-header-menu-wrap td-header-gradient">
			<div class="td-container td-header-row td-header-main-menu">
				<div id="td-header-menu">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo">
            <a href="http://blogs.jccc.edu/campusledger/">
        <img class="td-retina-data" data-retina="http://blogs.jccc.edu/campusledger/files/2016/09/LedgerBannerSpring16-retina-300x99.png" src="http://blogs.jccc.edu/campusledger/files/2016/09/LedgerBannerSpring16.png" alt=""/>
    </a>
    </div>
    <div class="menu-main-nav-container"><ul id="menu-main-nav-1" class="sf-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-mega-menu menu-item-4884"><a href="http://blogs.jccc.edu/campusledger/news/">News</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_1_589deb5db686d = new tdBlock();
block_td_uid_1_589deb5db686d.id = "td_uid_1_589deb5db686d";
block_td_uid_1_589deb5db686d.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"3","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","class":"td_uid_1_589deb5db686d_rand"}';
block_td_uid_1_589deb5db686d.td_column_number = "3";
block_td_uid_1_589deb5db686d.block_type = "td_block_mega_menu";
block_td_uid_1_589deb5db686d.post_count = "5";
block_td_uid_1_589deb5db686d.found_posts = "650";
block_td_uid_1_589deb5db686d.header_color = "";
block_td_uid_1_589deb5db686d.ajax_pagination_infinite_stop = "";
block_td_uid_1_589deb5db686d.max_num_pages = "130";
tdBlocksArray.push(block_td_uid_1_589deb5db686d);
</script><div class="td_block_wrap td_block_mega_menu td_uid_1_589deb5db686d_rand  td-no-subcats td_with_ajax_pagination td-pb-border-top"><div id=td_uid_1_589deb5db686d class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2017/02/02/students-faculty-respond-to-trumps-travel-ban/" rel="bookmark" title="Students, faculty respond to Trump&#8217;s travel ban"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2017/02/flaggraphic-218x150.png" alt="" title="Students, faculty respond to Trump&#8217;s travel ban"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2017/02/02/students-faculty-respond-to-trumps-travel-ban/" rel="bookmark" title="Students, faculty respond to Trump&#8217;s travel ban">Students, faculty respond to Trump&#8217;s travel ban</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2017/02/01/faculty-members-visit-topeka-in-support-of-firearms-ban/" rel="bookmark" title="Faculty members visit Topeka in support of firearms ban"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2017/02/800px-Kansas_State_Capitol-218x150.jpg" alt="" title="Faculty members visit Topeka in support of firearms ban"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2017/02/01/faculty-members-visit-topeka-in-support-of-firearms-ban/" rel="bookmark" title="Faculty members visit Topeka in support of firearms ban">Faculty members visit Topeka in support of firearms ban</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2017/01/31/anti-trump-protesters-gather-near-college/" rel="bookmark" title="Anti-Trump protesters gather near college"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2017/01/maxresdefault-2-218x150.jpg" alt="" title="Anti-Trump protesters gather near college"/><span class="td-video-play-ico"><img width="40" class="td-retina" src="http://blogs.jccc.edu/campusledger/wp-content/themes/Newspaper/images/icons/ico-video-large.png" alt="video"/></span></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2017/01/31/anti-trump-protesters-gather-near-college/" rel="bookmark" title="Anti-Trump protesters gather near college">Anti-Trump protesters gather near college</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2017/01/27/diners-given-meatless-options-at-veg-out-down-under/" rel="bookmark" title="Diners given meatless options at Veg Out Down Under"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2017/01/maxresdefault-1-218x150.jpg" alt="" title="Diners given meatless options at Veg Out Down Under"/><span class="td-video-play-ico"><img width="40" class="td-retina" src="http://blogs.jccc.edu/campusledger/wp-content/themes/Newspaper/images/icons/ico-video-large.png" alt="video"/></span></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2017/01/27/diners-given-meatless-options-at-veg-out-down-under/" rel="bookmark" title="Diners given meatless options at Veg Out Down Under">Diners given meatless options at Veg Out Down Under</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2017/01/26/professors-give-advice-on-prevention-for-flu-season/" rel="bookmark" title="Professors give advice on prevention for flu season"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2017/01/FluSeasonPhotoIllustration2-218x150.jpg" alt="" title="Professors give advice on prevention for flu season"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2017/01/26/professors-give-advice-on-prevention-for-flu-season/" rel="bookmark" title="Professors give advice on prevention for flu season">Professors give advice on prevention for flu season</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_1_589deb5db686d" data-td_block_id="td_uid_1_589deb5db686d"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_1_589deb5db686d" data-td_block_id="td_uid_1_589deb5db686d"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-mega-menu menu-item-4885"><a href="http://blogs.jccc.edu/campusledger/features/">Features</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_2_589deb5db9bcc = new tdBlock();
block_td_uid_2_589deb5db9bcc.id = "td_uid_2_589deb5db9bcc";
block_td_uid_2_589deb5db9bcc.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"14","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","class":"td_uid_2_589deb5db9bcc_rand"}';
block_td_uid_2_589deb5db9bcc.td_column_number = "3";
block_td_uid_2_589deb5db9bcc.block_type = "td_block_mega_menu";
block_td_uid_2_589deb5db9bcc.post_count = "5";
block_td_uid_2_589deb5db9bcc.found_posts = "396";
block_td_uid_2_589deb5db9bcc.header_color = "";
block_td_uid_2_589deb5db9bcc.ajax_pagination_infinite_stop = "";
block_td_uid_2_589deb5db9bcc.max_num_pages = "80";
tdBlocksArray.push(block_td_uid_2_589deb5db9bcc);
</script><div class="td_block_wrap td_block_mega_menu td_uid_2_589deb5db9bcc_rand  td-no-subcats td_with_ajax_pagination td-pb-border-top"><div id=td_uid_2_589deb5db9bcc class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2017/01/20/class-offered-to-help-students-gain-reading-and-writing-skills-in-spanish/" rel="bookmark" title="Class offered to help students gain reading and writing skills in Spanish"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2017/01/Irene-Schmidt-2-218x150.jpg" alt="" title="Class offered to help students gain reading and writing skills in Spanish"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2017/01/20/class-offered-to-help-students-gain-reading-and-writing-skills-in-spanish/" rel="bookmark" title="Class offered to help students gain reading and writing skills in Spanish">Class offered to help students gain reading and writing skills in&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2017/01/12/infocus-beekeeping-class-gives-students-hands-on-experience-in-the-hives/" rel="bookmark" title="InFocus: Beekeeping class gives students hands-on experience in the hives"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2017/01/Copy-of-BeekeepingEdit8-218x150.jpg" alt="" title="InFocus: Beekeeping class gives students hands-on experience in the hives"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2017/01/12/infocus-beekeeping-class-gives-students-hands-on-experience-in-the-hives/" rel="bookmark" title="InFocus: Beekeeping class gives students hands-on experience in the hives">InFocus: Beekeeping class gives students hands-on experience in the hives</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2017/01/11/home-away-from-home-housing-the-colleges-international-students/" rel="bookmark" title="Home away from home: housing the college&#8217;s international students"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2017/01/International-Student-Housing-Edit2-218x150.jpg" alt="" title="Home away from home: housing the college&#8217;s international students"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2017/01/11/home-away-from-home-housing-the-colleges-international-students/" rel="bookmark" title="Home away from home: housing the college&#8217;s international students">Home away from home: housing the college&#8217;s international students</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2016/12/14/hit-the-gym-beat-the-stress-finals-week-exercise/" rel="bookmark" title="Hit the gym, beat the stress; finals week exercise"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2016/12/BenefitsOfExerciseEdit1-218x150.jpg" alt="" title="Hit the gym, beat the stress; finals week exercise"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2016/12/14/hit-the-gym-beat-the-stress-finals-week-exercise/" rel="bookmark" title="Hit the gym, beat the stress; finals week exercise">Hit the gym, beat the stress; finals week exercise</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2016/12/07/former-student-excels-in-unusual-music/" rel="bookmark" title="Former student excels in unusual music"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2016/12/USEIanTeepleEdit2-218x150.jpg" alt="" title="Former student excels in unusual music"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2016/12/07/former-student-excels-in-unusual-music/" rel="bookmark" title="Former student excels in unusual music">Former student excels in unusual music</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_2_589deb5db9bcc" data-td_block_id="td_uid_2_589deb5db9bcc"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_2_589deb5db9bcc" data-td_block_id="td_uid_2_589deb5db9bcc"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-mega-menu menu-item-8920"><a href="http://blogs.jccc.edu/campusledger/entertainment/">Entertainment</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_3_589deb5dbc685 = new tdBlock();
block_td_uid_3_589deb5dbc685.id = "td_uid_3_589deb5dbc685";
block_td_uid_3_589deb5dbc685.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"2098","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","class":"td_uid_3_589deb5dbc685_rand"}';
block_td_uid_3_589deb5dbc685.td_column_number = "3";
block_td_uid_3_589deb5dbc685.block_type = "td_block_mega_menu";
block_td_uid_3_589deb5dbc685.post_count = "5";
block_td_uid_3_589deb5dbc685.found_posts = "72";
block_td_uid_3_589deb5dbc685.header_color = "";
block_td_uid_3_589deb5dbc685.ajax_pagination_infinite_stop = "";
block_td_uid_3_589deb5dbc685.max_num_pages = "15";
tdBlocksArray.push(block_td_uid_3_589deb5dbc685);
</script><div class="td_block_wrap td_block_mega_menu td_uid_3_589deb5dbc685_rand  td-no-subcats td_with_ajax_pagination td-pb-border-top"><div id=td_uid_3_589deb5dbc685 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2017/02/08/power-trip-delivers-thrash-metal-justice-on-nightmare-logic/" rel="bookmark" title="Power Trip delivers thrash metal justice on “Nightmare Logic”"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2017/02/ptriponline-218x150.png" alt="" title="Power Trip delivers thrash metal justice on “Nightmare Logic”"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2017/02/08/power-trip-delivers-thrash-metal-justice-on-nightmare-logic/" rel="bookmark" title="Power Trip delivers thrash metal justice on “Nightmare Logic”">Power Trip delivers thrash metal justice on “Nightmare Logic”</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2017/02/03/jcav-tv-video-roundup-super-bowl-predictions-student-concert-series-auditions/" rel="bookmark" title="JCAV-TV Video Roundup: Super Bowl Predictions, Student Concert Series Auditions"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2017/02/rounduptemplate-218x150.png" alt="" title="JCAV-TV Video Roundup: Super Bowl Predictions, Student Concert Series Auditions"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2017/02/03/jcav-tv-video-roundup-super-bowl-predictions-student-concert-series-auditions/" rel="bookmark" title="JCAV-TV Video Roundup: Super Bowl Predictions, Student Concert Series Auditions">JCAV-TV Video Roundup: Super Bowl Predictions, Student Concert Series Auditions</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2017/01/26/book-review-relatable-killer-captures-readers-in-mystery-novel-hidden-bodies/" rel="bookmark" title="Relatable killer captures readers in mystery novel “Hidden Bodies”"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2017/01/bodies-218x150.png" alt="" title="Relatable killer captures readers in mystery novel “Hidden Bodies”"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2017/01/26/book-review-relatable-killer-captures-readers-in-mystery-novel-hidden-bodies/" rel="bookmark" title="Relatable killer captures readers in mystery novel “Hidden Bodies”">Relatable killer captures readers in mystery novel “Hidden Bodies”</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2016/11/18/mary-o-thrills-audiences-with-haunted-sea-travels/" rel="bookmark" title="&#8220;Mary O&#039;&#8221; thrills audiences with haunted sea travels"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2016/11/mary-o-pdf-218x150.jpg" alt="" title="&#8220;Mary O&#039;&#8221; thrills audiences with haunted sea travels"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2016/11/18/mary-o-thrills-audiences-with-haunted-sea-travels/" rel="bookmark" title="&#8220;Mary O&#039;&#8221; thrills audiences with haunted sea travels">&#8220;Mary O&#039;&#8221; thrills audiences with haunted sea travels</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2016/11/17/catching-kelce-ends-with-humiliation/" rel="bookmark" title="&#8220;Catching Kelce&#8221; ends with humiliation"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2016/11/kelce_S1_Desktop_ShowDetail_2560x1450_1280x725_753926211838-218x150.jpg" alt="" title="&#8220;Catching Kelce&#8221; ends with humiliation"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2016/11/17/catching-kelce-ends-with-humiliation/" rel="bookmark" title="&#8220;Catching Kelce&#8221; ends with humiliation">&#8220;Catching Kelce&#8221; ends with humiliation</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_3_589deb5dbc685" data-td_block_id="td_uid_3_589deb5dbc685"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_3_589deb5dbc685" data-td_block_id="td_uid_3_589deb5dbc685"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-mega-menu menu-item-4888"><a href="http://blogs.jccc.edu/campusledger/sports-2/">Sports</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_4_589deb5dbfc1d = new tdBlock();
block_td_uid_4_589deb5dbfc1d.id = "td_uid_4_589deb5dbfc1d";
block_td_uid_4_589deb5dbfc1d.atts = '{"limit":4,"td_column_number":3,"ajax_pagination":"next_prev","category_id":"16","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","class":"td_uid_4_589deb5dbfc1d_rand"}';
block_td_uid_4_589deb5dbfc1d.td_column_number = "3";
block_td_uid_4_589deb5dbfc1d.block_type = "td_block_mega_menu";
block_td_uid_4_589deb5dbfc1d.post_count = "4";
block_td_uid_4_589deb5dbfc1d.found_posts = "323";
block_td_uid_4_589deb5dbfc1d.header_color = "";
block_td_uid_4_589deb5dbfc1d.ajax_pagination_infinite_stop = "";
block_td_uid_4_589deb5dbfc1d.max_num_pages = "81";
tdBlocksArray.push(block_td_uid_4_589deb5dbfc1d);
</script>            <script>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</script>
            <div class="td_block_wrap td_block_mega_menu td_uid_4_589deb5dbfc1d_rand  td_with_ajax_pagination td-pb-border-top"><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_4_589deb5dbfc1d" id="td_uid_5_589deb5dc0a77" data-td_block_id="td_uid_4_589deb5dbfc1d" data-td_filter_value="" href="http://blogs.jccc.edu/campusledger/category/sports/">All</a><a class="mega-menu-sub-cat-td_uid_4_589deb5dbfc1d"  id="td_uid_6_589deb5dc0b5c" data-td_block_id="td_uid_4_589deb5dbfc1d" data-td_filter_value="2107" href="http://blogs.jccc.edu/campusledger/category/sports/sportsreport/">Cavalier Sports Report</a></div></div><div id=td_uid_4_589deb5dbfc1d class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2017/02/09/experience-leadership-help-keep-team-members-eye-on-the-ball/" rel="bookmark" title="Experience, leadership help keep team members eye on the ball"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2017/02/Team-Edit1-218x150.jpg" alt="" title="Experience, leadership help keep team members eye on the ball"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2017/02/09/experience-leadership-help-keep-team-members-eye-on-the-ball/" rel="bookmark" title="Experience, leadership help keep team members eye on the ball">Experience, leadership help keep team members eye on the ball</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2017/01/23/preparation-and-consistency-help-womens-basketball-team-score-big/" rel="bookmark" title="Preparation and consistency help women’s basketball team score big"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2017/01/DSC0601-218x150.jpg" alt="" title="Preparation and consistency help women’s basketball team score big"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2017/01/23/preparation-and-consistency-help-womens-basketball-team-score-big/" rel="bookmark" title="Preparation and consistency help women’s basketball team score big">Preparation and consistency help women’s basketball team score big</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2016/12/13/two-womens-soccer-players-sign-to-columbia-college/" rel="bookmark" title="Two women’s soccer players sign to Columbia College"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2016/12/Copy-of-Edit-2-218x150.jpg" alt="" title="Two women’s soccer players sign to Columbia College"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2016/12/13/two-womens-soccer-players-sign-to-columbia-college/" rel="bookmark" title="Two women’s soccer players sign to Columbia College">Two women’s soccer players sign to Columbia College</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2016/11/24/mens-basketball-team-begins-season-with-national-championship-in-mind/" rel="bookmark" title="Men’s basketball team begins season with national championship in mind"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2016/11/Basketball_Practice_1122016_Edit1-218x150.jpg" alt="" title="Men’s basketball team begins season with national championship in mind"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2016/11/24/mens-basketball-team-begins-season-with-national-championship-in-mind/" rel="bookmark" title="Men’s basketball team begins season with national championship in mind">Men’s basketball team begins season with national championship in mind</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_4_589deb5dbfc1d" data-td_block_id="td_uid_4_589deb5dbfc1d"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_4_589deb5dbfc1d" data-td_block_id="td_uid_4_589deb5dbfc1d"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-mega-menu menu-item-4887"><a href="http://blogs.jccc.edu/campusledger/opinion/">Opinion</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_7_589deb5dc6239 = new tdBlock();
block_td_uid_7_589deb5dc6239.id = "td_uid_7_589deb5dc6239";
block_td_uid_7_589deb5dc6239.atts = '{"limit":4,"td_column_number":3,"ajax_pagination":"next_prev","category_id":"8","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","class":"td_uid_7_589deb5dc6239_rand"}';
block_td_uid_7_589deb5dc6239.td_column_number = "3";
block_td_uid_7_589deb5dc6239.block_type = "td_block_mega_menu";
block_td_uid_7_589deb5dc6239.post_count = "4";
block_td_uid_7_589deb5dc6239.found_posts = "274";
block_td_uid_7_589deb5dc6239.header_color = "";
block_td_uid_7_589deb5dc6239.ajax_pagination_infinite_stop = "";
block_td_uid_7_589deb5dc6239.max_num_pages = "69";
tdBlocksArray.push(block_td_uid_7_589deb5dc6239);
</script>            <script>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</script>
            <div class="td_block_wrap td_block_mega_menu td_uid_7_589deb5dc6239_rand  td_with_ajax_pagination td-pb-border-top"><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_7_589deb5dc6239" id="td_uid_8_589deb5dc6df5" data-td_block_id="td_uid_7_589deb5dc6239" data-td_filter_value="" href="http://blogs.jccc.edu/campusledger/category/opinion/">All</a><a class="mega-menu-sub-cat-td_uid_7_589deb5dc6239"  id="td_uid_9_589deb5dc6ec7" data-td_block_id="td_uid_7_589deb5dc6239" data-td_filter_value="2104" href="http://blogs.jccc.edu/campusledger/category/opinion/letter-to-the-editor/">Letter to the Editor</a></div></div><div id=td_uid_7_589deb5dc6239 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2017/01/18/staff-editorial-be-wary-of-fake-news-those-spreading-it/" rel="bookmark" title="Staff Editorial: Be wary of fake news, those spreading it"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2017/01/staffed-218x150.png" alt="" title="Staff Editorial: Be wary of fake news, those spreading it"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2017/01/18/staff-editorial-be-wary-of-fake-news-those-spreading-it/" rel="bookmark" title="Staff Editorial: Be wary of fake news, those spreading it">Staff Editorial: Be wary of fake news, those spreading it</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2017/01/18/guest-column-in-defense-of-trump/" rel="bookmark" title="Guest column: In defense of Trump"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2017/01/guestcolumn-218x150.png" alt="" title="Guest column: In defense of Trump"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2017/01/18/guest-column-in-defense-of-trump/" rel="bookmark" title="Guest column: In defense of Trump">Guest column: In defense of Trump</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2016/12/08/thoughtful-gifts-dont-mean-empty-wallets/" rel="bookmark" title="Thoughtful gifts don’t mean empty wallets"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2016/12/AnniePortrait2-218x150.jpg" alt="" title="Thoughtful gifts don’t mean empty wallets"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2016/12/08/thoughtful-gifts-dont-mean-empty-wallets/" rel="bookmark" title="Thoughtful gifts don’t mean empty wallets">Thoughtful gifts don’t mean empty wallets</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2016/12/02/on-witnessing-trumps-election-as-an-international-student/" rel="bookmark" title="On witnessing Trump&#8217;s election as an international student"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2016/12/900px-Flag_of_Uganda.svg_-218x150.png" alt="" title="On witnessing Trump&#8217;s election as an international student"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2016/12/02/on-witnessing-trumps-election-as-an-international-student/" rel="bookmark" title="On witnessing Trump&#8217;s election as an international student">On witnessing Trump&#8217;s election as an international student</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_7_589deb5dc6239" data-td_block_id="td_uid_7_589deb5dc6239"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_7_589deb5dc6239" data-td_block_id="td_uid_7_589deb5dc6239"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-mega-menu menu-item-4890"><a href="http://blogs.jccc.edu/campusledger/multimedia/">JCAV-TV</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_10_589deb5dcb42e = new tdBlock();
block_td_uid_10_589deb5dcb42e.id = "td_uid_10_589deb5dcb42e";
block_td_uid_10_589deb5dcb42e.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"2097","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","class":"td_uid_10_589deb5dcb42e_rand"}';
block_td_uid_10_589deb5dcb42e.td_column_number = "3";
block_td_uid_10_589deb5dcb42e.block_type = "td_block_mega_menu";
block_td_uid_10_589deb5dcb42e.post_count = "5";
block_td_uid_10_589deb5dcb42e.found_posts = "111";
block_td_uid_10_589deb5dcb42e.header_color = "";
block_td_uid_10_589deb5dcb42e.ajax_pagination_infinite_stop = "";
block_td_uid_10_589deb5dcb42e.max_num_pages = "23";
tdBlocksArray.push(block_td_uid_10_589deb5dcb42e);
</script><div class="td_block_wrap td_block_mega_menu td_uid_10_589deb5dcb42e_rand  td-no-subcats td_with_ajax_pagination td-pb-border-top"><div id=td_uid_10_589deb5dcb42e class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2017/02/03/jcav-tv-video-roundup-super-bowl-predictions-student-concert-series-auditions/" rel="bookmark" title="JCAV-TV Video Roundup: Super Bowl Predictions, Student Concert Series Auditions"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2017/02/rounduptemplate-218x150.png" alt="" title="JCAV-TV Video Roundup: Super Bowl Predictions, Student Concert Series Auditions"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2017/02/03/jcav-tv-video-roundup-super-bowl-predictions-student-concert-series-auditions/" rel="bookmark" title="JCAV-TV Video Roundup: Super Bowl Predictions, Student Concert Series Auditions">JCAV-TV Video Roundup: Super Bowl Predictions, Student Concert Series Auditions</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2017/01/31/anti-trump-protesters-gather-near-college/" rel="bookmark" title="Anti-Trump protesters gather near college"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2017/01/maxresdefault-2-218x150.jpg" alt="" title="Anti-Trump protesters gather near college"/><span class="td-video-play-ico"><img width="40" class="td-retina" src="http://blogs.jccc.edu/campusledger/wp-content/themes/Newspaper/images/icons/ico-video-large.png" alt="video"/></span></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2017/01/31/anti-trump-protesters-gather-near-college/" rel="bookmark" title="Anti-Trump protesters gather near college">Anti-Trump protesters gather near college</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2017/01/27/diners-given-meatless-options-at-veg-out-down-under/" rel="bookmark" title="Diners given meatless options at Veg Out Down Under"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2017/01/maxresdefault-1-218x150.jpg" alt="" title="Diners given meatless options at Veg Out Down Under"/><span class="td-video-play-ico"><img width="40" class="td-retina" src="http://blogs.jccc.edu/campusledger/wp-content/themes/Newspaper/images/icons/ico-video-large.png" alt="video"/></span></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2017/01/27/diners-given-meatless-options-at-veg-out-down-under/" rel="bookmark" title="Diners given meatless options at Veg Out Down Under">Diners given meatless options at Veg Out Down Under</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2017/01/23/students-and-faculty-respond-to-trumps-inauguration/" rel="bookmark" title="Students and faculty respond to Trump&#8217;s inauguration"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2017/01/maxresdefault-218x150.jpg" alt="" title="Students and faculty respond to Trump&#8217;s inauguration"/><span class="td-video-play-ico"><img width="40" class="td-retina" src="http://blogs.jccc.edu/campusledger/wp-content/themes/Newspaper/images/icons/ico-video-large.png" alt="video"/></span></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2017/01/23/students-and-faculty-respond-to-trumps-inauguration/" rel="bookmark" title="Students and faculty respond to Trump&#8217;s inauguration">Students and faculty respond to Trump&#8217;s inauguration</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2017/01/05/bookstore-tips-for-avoiding-those-big-lines/" rel="bookmark" title="Bookstore tips for avoiding those big lines"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2017/01/FullSizeRender-1-218x150.jpg" alt="" title="Bookstore tips for avoiding those big lines"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2017/01/05/bookstore-tips-for-avoiding-those-big-lines/" rel="bookmark" title="Bookstore tips for avoiding those big lines">Bookstore tips for avoiding those big lines</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_10_589deb5dcb42e" data-td_block_id="td_uid_10_589deb5dcb42e"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_10_589deb5dcb42e" data-td_block_id="td_uid_10_589deb5dcb42e"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-8715"><a href="http://blogs.jccc.edu/ecavradio/">ECAV Radio</a></li>
</ul></div></div>


<div class="td-search-wrapper">
    <div id="td-top-search">
        <!-- Search -->
        <div class="header-search-wrap">
            <div class="dropdown header-search">
                <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            </div>
        </div>
    </div>
</div>

<div class="header-search-wrap">
	<div class="dropdown header-search">
		<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
			<form role="search" method="get" class="td-search-form" action="http://blogs.jccc.edu/campusledger/">
				<div class="td-head-form-search-wrap">
					<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
				</div>
			</form>
			<div id="td-aj-search"></div>
		</div>
	</div>
</div>			</div>
		</div>
	</div>

    <div class="td-banner-wrap-full td-banner-bg">
        <div class="td-container-header td-header-row td-header-header">
            <div class="td-header-sp-recs">
                <div class="td-header-rec-wrap">
    
</div>            </div>
        </div>
    </div>

</div><div class="td-main-content-wrap">

    <div class="td-container td-post-template-default ">
        <div class="td-crumb-container"><div class="entry-crumbs"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="" class="entry-crumb" itemprop="url" href="http://blogs.jccc.edu/campusledger/"><span itemprop="title">Home</span></a></span> <i class="td-icon-right td-bread-sep"></i> <span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="View all posts in Entertainment" class="entry-crumb" itemprop="url" href="http://blogs.jccc.edu/campusledger/category/entertainment/"><span itemprop="title">Entertainment</span></a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last" itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><meta itemprop="title" content = "Power Trip delivers thrash metal justice on “Nightmare Logic”"><meta itemprop="url" content = "http://blogs.jccc.edu/campusledger/2017/02/08/power-trip-delivers-thrash-metal-justice-on-nightmare-logic/">Power Trip delivers thrash metal justice on “Nightmare Logic”</span></div></div>

        <div class="td-pb-row">
                                    <div class="td-pb-span8 td-main-content" role="main">
                            <div class="td-ss-main-content">
                                
    <article id="post-10494" class="post-10494 post type-post status-publish format-standard has-post-thumbnail hentry category-entertainment tag-album-review tag-metal tag-music tag-nightmare-logic tag-power-trip" itemscope itemtype="http://schema.org/Article">
        <div class="td-post-header">

            <ul class="td-category"><li class="entry-category"><a  href="http://blogs.jccc.edu/campusledger/category/entertainment/">Entertainment</a></li></ul>
            <header class="td-post-title">
                <h1 class="entry-title">Power Trip delivers thrash metal justice on “Nightmare Logic”</h1>

                

                <div class="td-module-meta-info">
                                        <div class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-02-08T10:59:49+00:00" >February 8, 2017</time></div>                    <div class="td-post-comments"><a href="http://blogs.jccc.edu/campusledger/2017/02/08/power-trip-delivers-thrash-metal-justice-on-nightmare-logic/#respond"><i class="td-icon-comments"></i>0</a></div>                                    </div>

            </header>

        </div>

        <div class="td-post-sharing td-post-sharing-top ">
				<div class="td-default-sharing">
		            <a class="td-social-sharing-buttons td-social-facebook" href="http://www.facebook.com/sharer.php?u=http%3A%2F%2Fblogs.jccc.edu%2Fcampusledger%2F2017%2F02%2F08%2Fpower-trip-delivers-thrash-metal-justice-on-nightmare-logic%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-facebook"></i><div class="td-social-but-text">Share on Facebook</div></a>
		            <a class="td-social-sharing-buttons td-social-twitter" href="https://twitter.com/intent/tweet?text=Power+Trip+delivers+thrash+metal+justice+on+%E2%80%9CNightmare+Logic%E2%80%9D&url=http%3A%2F%2Fblogs.jccc.edu%2Fcampusledger%2F2017%2F02%2F08%2Fpower-trip-delivers-thrash-metal-justice-on-nightmare-logic%2F&via=campusledger"  ><i class="td-icon-twitter"></i><div class="td-social-but-text">Tweet on Twitter</div></a>
		            <a class="td-social-sharing-buttons td-social-google" href="http://plus.google.com/share?url=http://blogs.jccc.edu/campusledger/2017/02/08/power-trip-delivers-thrash-metal-justice-on-nightmare-logic/" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-googleplus"></i></a>
		            <a class="td-social-sharing-buttons td-social-pinterest" href="http://pinterest.com/pin/create/button/?url=http://blogs.jccc.edu/campusledger/2017/02/08/power-trip-delivers-thrash-metal-justice-on-nightmare-logic/&amp;media=http://blogs.jccc.edu/campusledger/files/2017/02/ptriponline.png&description=Power+Trip+delivers+thrash+metal+justice+on+%E2%80%9CNightmare+Logic%E2%80%9D" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-pinterest"></i></a>
		            <a class="td-social-sharing-buttons td-social-whatsapp" href="whatsapp://send?text=Power+Trip+delivers+thrash+metal+justice+on+%E2%80%9CNightmare+Logic%E2%80%9D - http%3A%2F%2Fblogs.jccc.edu%2Fcampusledger%2F2017%2F02%2F08%2Fpower-trip-delivers-thrash-metal-justice-on-nightmare-logic%2F" ><i class="td-icon-whatsapp"></i></a>
	            </div></div>

        <div class="td-post-content">

        <div class="td-post-featured-image"><figure><a href="http://blogs.jccc.edu/campusledger/files/2017/02/ptriponline.png" data-caption="Power Trip&#039;s second album &quot;Nightmare Logic&quot; is out via Southern Lord Recordings on Feb. 24, 2017."><img width="682" height="450" class="entry-thumb td-modal-image" src="http://blogs.jccc.edu/campusledger/files/2017/02/ptriponline.png" alt="" title="ptriponline"/></a><figcaption class="wp-caption-text">Power Trip's second album "Nightmare Logic" is out via Southern Lord Recordings on Feb. 24, 2017.</figcaption></figure></div>
        <p><strong>Aaron Rhodes</strong></p>
<p><em>Editor-in-chief</em></p>
<p><em>arhodes2@jccc.edu</em></p>
<p><span style="font-weight: 400">Power Trip is five-piece crossover thrash metal band from Dallas, Texas. Since its formation in 2008, the group has released several tapes and EPs, as well as one full-length album. That full-length, 2013’s “Manifest Decimation,” cemented the band’s status as a modern act well-versed in its genre’s past. The album also decimated the right people&#8217;s ears as well, seeing that the band was invited to tour with heavy hitters like Anthrax and Eyehategod in the years that followed.</span></p>
<p><span style="font-weight: 400">Now, after nearly four years, Power Trip has returned with a new record. “Nightmare Logic” is its second offering on Southern Lord Recordings, and is equipped to win over any thrash metal purists that “Manifest Decimation” may have missed.</span></p>
<p><span style="font-weight: 400">The band has upped its game instrumentally. Its two guitarists are hard at work, packing in lightning-fast solos that easily best those on the previous album. “Firing Squad” is a particularly vicious track that administers blistering solos along with the half-time mosh riffs that fans of the hardcore genre love so dearly.</span></p>
<p><span style="font-weight: 400">Another element that makes “Nightmare Logic” such a complete offering is its lyrics. Vocalist Riley Gale’s gravelly aggression is far less vague than the average metal album. Gale sets his sights on the dangers perpetrated by the pharmaceutical industry on one track and his distaste for morally bankrupt politicians on another.</span></p>
<p><span style="font-weight: 400">“Nightmare Logic” builds off everything the band has done before, while inching ever closer to the thrash perfection achieved by Slayer and other greats of the genre. The album plays like eight swift slashes from a rusted scythe, simultaneously chopping listeners to pieces and uniting them under a just cause.</span></p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-10494" class="share-facebook sd-button share-icon no-text" href="http://blogs.jccc.edu/campusledger/2017/02/08/power-trip-delivers-thrash-metal-justice-on-nightmare-logic/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-10494" class="share-twitter sd-button share-icon no-text" href="http://blogs.jccc.edu/campusledger/2017/02/08/power-trip-delivers-thrash-metal-justice-on-nightmare-logic/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button share-icon no-text" href="http://blogs.jccc.edu/campusledger/2017/02/08/power-trip-delivers-thrash-metal-justice-on-nightmare-logic/?share=email" target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-10494" class="share-google-plus-1 sd-button share-icon no-text" href="http://blogs.jccc.edu/campusledger/2017/02/08/power-trip-delivers-thrash-metal-justice-on-nightmare-logic/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span></span><span class="sharing-screen-reader-text">Click to share on Google+ (Opens in new window)</span></a></li><li class="share-print"><a rel="nofollow" data-shared="" class="share-print sd-button share-icon no-text" href="http://blogs.jccc.edu/campusledger/2017/02/08/power-trip-delivers-thrash-metal-justice-on-nightmare-logic/#print" target="_blank" title="Click to print"><span></span><span class="sharing-screen-reader-text">Click to print (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon no-text" href="http://blogs.jccc.edu/campusledger/2017/02/08/power-trip-delivers-thrash-metal-justice-on-nightmare-logic/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li><a href="#" class="sharing-anchor sd-button share-more"><span>More</span></a></li><li class="share-end"></li></ul><div class="sharing-hidden"><div class="inner" style="display: none;"><ul><li class="share-press-this"><a rel="nofollow" data-shared="" class="share-press-this sd-button share-icon no-text" href="http://blogs.jccc.edu/campusledger/2017/02/08/power-trip-delivers-thrash-metal-justice-on-nightmare-logic/?share=press-this" target="_blank" title="Click to Press This!"><span></span><span class="sharing-screen-reader-text">Click to Press This! (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow" data-shared="sharing-linkedin-10494" class="share-linkedin sd-button share-icon no-text" href="http://blogs.jccc.edu/campusledger/2017/02/08/power-trip-delivers-thrash-metal-justice-on-nightmare-logic/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-end"></li><li class="share-end"></li></ul></div></div></div></div></div>        </div>


        <footer>
                        
            <div class="td-post-source-tags">
                                <ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="http://blogs.jccc.edu/campusledger/tag/album-review/">album review</a></li><li><a href="http://blogs.jccc.edu/campusledger/tag/metal/">metal</a></li><li><a href="http://blogs.jccc.edu/campusledger/tag/music/">music</a></li><li><a href="http://blogs.jccc.edu/campusledger/tag/nightmare-logic/">nightmare logic</a></li><li><a href="http://blogs.jccc.edu/campusledger/tag/power-trip/">power trip</a></li></ul>            </div>

            <div class="td-post-sharing td-post-sharing-bottom td-with-like"><span class="td-post-share-title">SHARE</span>
            <div class="td-default-sharing">
	            <a class="td-social-sharing-buttons td-social-facebook" href="http://www.facebook.com/sharer.php?u=http%3A%2F%2Fblogs.jccc.edu%2Fcampusledger%2F2017%2F02%2F08%2Fpower-trip-delivers-thrash-metal-justice-on-nightmare-logic%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-facebook"></i><div class="td-social-but-text">Facebook</div></a>
	            <a class="td-social-sharing-buttons td-social-twitter" href="https://twitter.com/intent/tweet?text=Power+Trip+delivers+thrash+metal+justice+on+%E2%80%9CNightmare+Logic%E2%80%9D&url=http%3A%2F%2Fblogs.jccc.edu%2Fcampusledger%2F2017%2F02%2F08%2Fpower-trip-delivers-thrash-metal-justice-on-nightmare-logic%2F&via=campusledger"><i class="td-icon-twitter"></i><div class="td-social-but-text">Twitter</div></a>
	            <a class="td-social-sharing-buttons td-social-google" href="http://plus.google.com/share?url=http://blogs.jccc.edu/campusledger/2017/02/08/power-trip-delivers-thrash-metal-justice-on-nightmare-logic/" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-googleplus"></i></a>
	            <a class="td-social-sharing-buttons td-social-pinterest" href="http://pinterest.com/pin/create/button/?url=http://blogs.jccc.edu/campusledger/2017/02/08/power-trip-delivers-thrash-metal-justice-on-nightmare-logic/&amp;media=http://blogs.jccc.edu/campusledger/files/2017/02/ptriponline.png&description=Power+Trip+delivers+thrash+metal+justice+on+%E2%80%9CNightmare+Logic%E2%80%9D" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-pinterest"></i></a>
	            <a class="td-social-sharing-buttons td-social-whatsapp" href="whatsapp://send?text=Power+Trip+delivers+thrash+metal+justice+on+%E2%80%9CNightmare+Logic%E2%80%9D - http%3A%2F%2Fblogs.jccc.edu%2Fcampusledger%2F2017%2F02%2F08%2Fpower-trip-delivers-thrash-metal-justice-on-nightmare-logic%2F" ><i class="td-icon-whatsapp"></i></a>
            </div><div class="td-classic-sharing"><ul><li class="td-classic-facebook"><iframe frameBorder="0" src="http://www.facebook.com/plugins/like.php?href=http://blogs.jccc.edu/campusledger/2017/02/08/power-trip-delivers-thrash-metal-justice-on-nightmare-logic/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:105px; height:21px; background-color:transparent;"></iframe></li><li class="td-classic-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="http://blogs.jccc.edu/campusledger/2017/02/08/power-trip-delivers-thrash-metal-justice-on-nightmare-logic/" data-text="Power Trip delivers thrash metal justice on “Nightmare Logic”" data-via="" data-lang="en">tweet</a> <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></li></ul></div></div>            <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="http://blogs.jccc.edu/campusledger/2017/02/03/jcav-tv-video-roundup-super-bowl-predictions-student-concert-series-auditions/">JCAV-TV Video Roundup: Super Bowl Predictions, Student Concert Series Auditions</a></div></div><div class="td-next-prev-separator"></div><div class="td-block-span6 td-post-next-post"><div class="td-post-next-prev-content"><span>Next article</span><a href="http://blogs.jccc.edu/campusledger/2017/02/09/experience-leadership-help-keep-team-members-eye-on-the-ball/">Experience, leadership help keep team members eye on the ball</a></div></div></div>            <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="http://blogs.jccc.edu/campusledger/author/arhodes2/">arhodes2</a></span></div>	        <span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="arhodes2"></span><meta itemprop="datePublished" content="2017-02-08T10:59:49+00:00"><meta itemprop="dateModified" content="2017-02-08T11:00:25+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="http://blogs.jccc.edu/campusledger/2017/02/08/power-trip-delivers-thrash-metal-justice-on-nightmare-logic/"/><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://blogs.jccc.edu/campusledger/files/2016/09/LedgerBannerSpring16.png"></span><meta itemprop="name" content="The Campus Ledger"></span><meta itemprop="headline " content="Power Trip delivers thrash metal justice on “Nightmare Logic”"><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://blogs.jccc.edu/campusledger/files/2017/02/ptriponline.png"><meta itemprop="width" content="682"><meta itemprop="height" content="450"></span>        </footer>

    </article> <!-- /.post -->

    <script>var block_td_uid_11_589deb5dd2e77 = new tdBlock();
block_td_uid_11_589deb5dd2e77.id = "td_uid_11_589deb5dd2e77";
block_td_uid_11_589deb5dd2e77.atts = '{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"td_uid_11_589deb5dd2e77_rand","td_column_number":3,"live_filter_cur_post_id":10494,"live_filter_cur_post_author":"657"}';
block_td_uid_11_589deb5dd2e77.td_column_number = "3";
block_td_uid_11_589deb5dd2e77.block_type = "td_block_related_posts";
block_td_uid_11_589deb5dd2e77.post_count = "3";
block_td_uid_11_589deb5dd2e77.found_posts = "71";
block_td_uid_11_589deb5dd2e77.header_color = "";
block_td_uid_11_589deb5dd2e77.ajax_pagination_infinite_stop = "";
block_td_uid_11_589deb5dd2e77.max_num_pages = "24";
tdBlocksArray.push(block_td_uid_11_589deb5dd2e77);
</script><div class="td_block_wrap td_block_related_posts td_uid_11_589deb5dd2e77_rand td_with_ajax_pagination td-pb-border-top"><h4 class="td-related-title"><a id="td_uid_12_589deb5dd397b" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_11_589deb5dd2e77" href="#">RELATED ARTICLES</a><a id="td_uid_13_589deb5dd39c4" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_11_589deb5dd2e77" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_11_589deb5dd2e77 class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2017/02/03/jcav-tv-video-roundup-super-bowl-predictions-student-concert-series-auditions/" rel="bookmark" title="JCAV-TV Video Roundup: Super Bowl Predictions, Student Concert Series Auditions"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2017/02/rounduptemplate-218x150.png" alt="" title="JCAV-TV Video Roundup: Super Bowl Predictions, Student Concert Series Auditions"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2017/02/03/jcav-tv-video-roundup-super-bowl-predictions-student-concert-series-auditions/" rel="bookmark" title="JCAV-TV Video Roundup: Super Bowl Predictions, Student Concert Series Auditions">JCAV-TV Video Roundup: Super Bowl Predictions, Student Concert Series Auditions</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2017/01/26/book-review-relatable-killer-captures-readers-in-mystery-novel-hidden-bodies/" rel="bookmark" title="Relatable killer captures readers in mystery novel “Hidden Bodies”"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2017/01/bodies-218x150.png" alt="" title="Relatable killer captures readers in mystery novel “Hidden Bodies”"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2017/01/26/book-review-relatable-killer-captures-readers-in-mystery-novel-hidden-bodies/" rel="bookmark" title="Relatable killer captures readers in mystery novel “Hidden Bodies”">Relatable killer captures readers in mystery novel “Hidden Bodies”</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2016/11/18/mary-o-thrills-audiences-with-haunted-sea-travels/" rel="bookmark" title="&#8220;Mary O&#039;&#8221; thrills audiences with haunted sea travels"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2016/11/mary-o-pdf-218x150.jpg" alt="" title="&#8220;Mary O&#039;&#8221; thrills audiences with haunted sea travels"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2016/11/18/mary-o-thrills-audiences-with-haunted-sea-travels/" rel="bookmark" title="&#8220;Mary O&#039;&#8221; thrills audiences with haunted sea travels">&#8220;Mary O&#039;&#8221; thrills audiences with haunted sea travels</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_11_589deb5dd2e77" data-td_block_id="td_uid_11_589deb5dd2e77"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_11_589deb5dd2e77" data-td_block_id="td_uid_11_589deb5dd2e77"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->

	<div class="comments" id="comments">
        
            <div class="td-comments-title-wrap ">
                <h4 class="block-title"><span>NO COMMENTS</span></h4>
            </div>

            
		<div id="respond" class="comment-respond">
			<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/campusledger/2017/02/08/power-trip-delivers-thrash-metal-justice-on-nightmare-logic/#respond" style="display:none;">Cancel reply</a></small></h3>
			<form id="commentform" class="comment-form">
				<iframe src="https://jetpack.wordpress.com/jetpack-comment/?blogid=26340824&#038;postid=10494&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=blank&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=4.6&#038;sig=9862f486263adb1dac2f59928d7ae41846528783#parent=http%3A%2F%2Fblogs.jccc.edu%2Fcampusledger%2F2017%2F02%2F08%2Fpower-trip-delivers-thrash-metal-justice-on-nightmare-logic%2F" allowtransparency="false" style="width:100%; height: 430px;border:0;" frameBorder="0" scrolling="no" name="jetpack_remote_comment" id="jetpack_remote_comment"></iframe>
			</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		    </div> <!-- /.content -->
                            </div>
                        </div>
                        <div class="td-pb-span4 td-main-sidebar" role="complementary">
                            <div class="td-ss-main-sidebar">
                                <div class="td-a-rec td-a-rec-id-custom_ad_1 "><span class="td-adspot-title">-Advertisement-</span><a href="http://www.adviceandaid.com" target="_blank"><img src="http://blogs.jccc.edu/campusledger/files/2016/03/Advice-Aid-April-Cube.jpg"></a></div>                            </div>
                        </div>
                            </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</div> <!-- /.td-main-content-wrap -->


<!-- Footer -->
<div class="td-footer-wrapper">
    <div class="td-container">

	    <div class="td-pb-row">
		    <div class="td-pb-span12">
			    		    </div>
	    </div>

        <div class="td-pb-row">

            <div class="td-pb-span4">
                <aside class="widget widget_facebook_likebox"><div class="block-title"><span><a href="https://www.facebook.com/campusledger">Like us on Facebook</a></span></div>		<div id="fb-root"></div>
		<div class="fb-page" data-href="https://www.facebook.com/campusledger" data-width="340"  data-height="450" data-hide-cover="false" data-show-facepile="false" data-show-posts="true">
		<div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/campusledger"><a href="https://www.facebook.com/campusledger">Like us on Facebook</a></blockquote></div>
		</div>
		</aside>            </div>

            <div class="td-pb-span4">
                <aside class="widget widget_twitter_timeline"><div class="block-title"><span>Follow us on Twitter</span></div><a class="twitter-timeline" data-height="450" data-theme="light" data-link-color="#f96e5b" data-border-color="#e8e8e8" data-lang="EN" data-partner="jetpack" data-widget-id="505563953364082688">My Tweets</a></aside>            </div>

            <div class="td-pb-span4">
                <aside class="widget widget_pages"><div class="block-title"><span>Sections</span></div>		<ul>
			<li class="page_item page-item-77"><a href="http://blogs.jccc.edu/campusledger/news/">News</a></li>
<li class="page_item page-item-81"><a href="http://blogs.jccc.edu/campusledger/features/">Features</a></li>
<li class="page_item page-item-8899"><a href="http://blogs.jccc.edu/campusledger/entertainment/">Entertainment</a></li>
<li class="page_item page-item-75"><a href="http://blogs.jccc.edu/campusledger/sports-2/">Sports</a></li>
<li class="page_item page-item-79"><a href="http://blogs.jccc.edu/campusledger/opinion/">Opinion</a></li>
<li class="page_item page-item-1781"><a href="http://blogs.jccc.edu/campusledger/multimedia/">JCAV-TV</a></li>
<li class="page_item page-item-1986"><a href="http://blogs.jccc.edu/campusledger/letters-to-the-editor/">Letters to the Editor</a></li>
<li class="page_item page-item-1786"><a href="http://blogs.jccc.edu/campusledger/submit-a-story-idea/">Submit a Story Idea</a></li>
		</ul>
		</aside><aside class="widget widget_contact_info"><div class="block-title"><span>Contact us</span></div><div class="confit-address"><a href="https://maps.google.com/maps?z=16&#038;q=student+news+center,+com+260+12345+college+blvd.+overland+park,+ks+66210" target="_blank">Student News Center, COM 260<br/>12345 College Blvd.<br/>Overland Park, KS 66210</a></div><div class="confit-phone">913.469.8500 ext. 3193</div></aside>            </div>
        </div>
    </div>
<div class="td-footer-bottom-full">
    <div class="td-container">
        <div class="td-pb-row">
            <div class="td-pb-span3"><aside class="footer-logo-wrap"><a href="http://blogs.jccc.edu/campusledger/"><img class="td-retina-data" src="http://blogs.jccc.edu/campusledger/files/2016/03/LedgerBannerSpring16-08-300x111.jpg" data-retina="http://blogs.jccc.edu/campusledger/files/2016/03/LedgerBannerSpring16-08-1024x379.jpg" alt=""/></a></aside></div><div class="td-pb-span5"><aside class="footer-text-wrap"><div class="block-title"><span>ABOUT US</span></div><i>The Campus Ledger</i>, an All-American publication, an Associated Collegiate Press Pacemaker finalist and Midwest Pacemaker winner, is the official student news outlet of Johnson County Community College. <i>Ledger</i> content focuses on the campus community, local and national issues with a campus connection, and other issues of interest to our readers. <i>The Ledger</i> defines, identifies, and reports news. Content is published online daily and our print edition is published monthly. </aside></div><div class="td-pb-span4"><aside class="footer-social-wrap td-social-style-2"><div class="block-title"><span>FOLLOW US</span></div><span class="td-social-icon-wrap"><a target="_blank" href="https://www.facebook.com/CampusLedger/" title="Facebook"><i class="td-icon-font td-icon-facebook"></i></a></span><span class="td-social-icon-wrap"><a target="_blank" href="http://www.twitter.com/campusledger" title="Twitter"><i class="td-icon-font td-icon-twitter"></i></a></span><span class="td-social-icon-wrap"><a target="_blank" href="https://www.youtube.com/user/jcccjcavtv" title="Youtube"><i class="td-icon-font td-icon-youtube"></i></a></span></aside></div>        </div>
    </div>
</div>
</div>

<!-- Sub Footer -->
    </div><!--close content div-->
</div><!--close td-outer-wrap-->


<!-- Highlight Search Terms 1.4.3 ( RavanH - http://status301.net/wordpress-plugins/highlight-search-terms/ ) -->
<script type="text/javascript">
var hlst_query = new Array("");
var hlst_areas = new Array("#groups-dir-list","#members-dir-list","div.bbp-topic-content,div.bbp-reply-content,li.bbp-forum-info,.bbp-topic-title,.bbp-reply-title","article","div.hentry","div.post","#content","#main","div.content","#middle","#container","div.container","div.page","#wrapper","body");
</script>
<div id="wpmsgcheader"></div><div id="wpmsgcfooter"><style type="text/css">
.jccc-blogs-global a {
    color: #337AB7;
    text-decoration: none;
        text-decoration-color: -moz-use-text-color;
        text-decoration-line: none;
        text-decoration-style: solid;
    background-color: transparent;
}
footer.jccc-blogs-global {
    padding-bottom: 20px;
    padding-top: 20px;
    display: block;
    font-family: "Helvetica Neue",Helvetica,Arial,sans-serif;
    font-size: 14px;
    line-height: 1.42857;
    color: #333;
    background-color: white;
    height: 180px;
}
@media (min-width: 768px) {
	.jccc-blogs-global-container {
		width: 750px;
	}
}
@media (min-width: 992px) {
	.jccc-blogs-global-container {
	    width: 970px;
	}
	.col-md-12 {
		width: 100%;
		float: left;
	}
}
@media (min-width: 1200px) {
	.jccc-blogs-global-container {
	    width: 1170px;
	}
}
.jccc-blogs-global-container {
	padding-right: 15px;
    padding-left: 15px;
    margin-right: auto;
    margin-left: auto;
}
.jccc-blogs-global-row {
    margin-right: -15px;
    margin-left: -15px;
}
.col-md-2, .col-sm-2 {
    width: 16.6667%;
    float: left;
    position: relative;
    min-height: 1px;
    padding-right: 15px;
        padding-right-value: 15px;
        padding-right-ltr-source: physical;
        padding-right-rtl-source: physical;
    padding-left: 15px;
        padding-left-value: 15px;
        padding-left-ltr-source: physical;
        padding-left-rtl-source: physical;
    box-sizing: border-box;
}
.col-md-12 {
    position: relative;
    min-height: 1px;
    padding-right: 15px;
        padding-right-value: 15px;
        padding-right-ltr-source: physical;
        padding-right-rtl-source: physical;
    padding-left: 15px;
        padding-left-value: 15px;
        padding-left-ltr-source: physical;
        padding-left-rtl-source: physical;
    box-sizing: border-box;
    margin-top: 20px;
}
.jccc-blogs-global-list-unstyled {
    padding-left: 0px;
    list-style: outside none none;
}
.jccc-blogs-global-small {
    font-size: 85%;
}
.jccc-blogs-global ul, .jccc-blogs-global ol {
    margin-top: 0px;
    margin-bottom: 10px;
}
.visible-xs, .visible-sm, .visible-md, .visible-lg {
    display: none !important;
}
footer #social-links {
    max-width: 120px;
    margin: 0px auto;
        margin-top: 0px;
        margin-right-value: auto;
        margin-bottom: 0px;
        margin-left-value: auto;
        margin-left-ltr-source: physical;
        margin-left-rtl-source: physical;
        margin-right-ltr-source: physical;
        margin-right-rtl-source: physical;
}
.fa {
    vertical-align: middle;
    display: inline-block;
    font-family: FontAwesome;
    font-style: normal;
    font-weight: normal;
    line-height: 1;
}
footer #social-links .fa {
    padding-top: 2px;
    border-radius: 6px;
	    border-top-left-radius: 6px;
	    border-top-right-radius: 6px;
	    border-bottom-right-radius: 6px;
	    border-bottom-left-radius: 6px;
    background-color: #0094B3;
    color: #FFF;
    float: left;
    margin-left: 4px;
	    margin-left-value: 4px;
	    margin-left-ltr-source: physical;
	    margin-left-rtl-source: physical;
    margin-bottom: 4px;
}
.fa-fw {
    width: 1.28571em;
    text-align: center;
}
.fa-2x {
    font-size: 2em;
}
#footer-address, #police-dept {
    text-align: center;
}
#footer-address br, #police-dept br {
    display: none;
}
.jccc-blogs-global b, .jccc-blogs-global strong {
    font-weight: 700;
}


</style>
	<footer class="jccc-blogs-global">
		<div class="jccc-blogs-global-container">
			<div class="jccc-blogs-global-row">
				<div class="col-sm-2 col-md-2">
					<a href="http://www.jccc.edu">
					<img alt="Johnson County Community College" class="logo" src="http://blogs.jccc.edu/wp-content/uploads/2015/04/120xNxlogoalt2x.png.pagespeed.ic_.34Y3n1O0UZ.png" pagespeed_url_hash="3029252065" width="120"/></a>
				</div>
<!-- Footer Menu -->
				<system-region name="DEFAULT">
					<div class="hidden-xs col-md-2 col-sm-2">
						<ul class="jccc-blogs-global-list-unstyled jccc-blogs-global-small">
							<li><a href="http://www.jccc.edu/about"> About JCCC</a></li>
							<li><a href="http://www.jccc.edu/academics"> Academics & Training</a></li>
							<li><a href="http://www.jccc.edu/admissions"> Admissions</a></li>
							<li><a href="http://www.jccc.edu/student-resources"> Student Resources</a></li>
							<li><a href="http://www.jccc.edu/professional-resources"> Professional Services</a></li>
							<li><a href="http://www.jccc.edu/community-resources"> Community Services</a></li>
						</ul>
					</div>
					<div class="hidden-xs col-md-2 col-sm-2">
						<ul class="jccc-blogs-global-list-unstyled jccc-blogs-global-small">
							<li><a href="http://www.jccc.edu/newsroom"> Newsroom</a></li>
							<li><a href="http://www.jccc.edu/events"> Events</a></li>
							<li><a href="http://www.jccc.edu/about/leadership-governance/administration"> Administration</a></li>
							<li><a href="http://www.jccc.edu/about/leadership-governance/administration/human-resources/careers.html"> Careers</a></li>
							<li><a href="http://www.jccc.edu/about/contacts.html"> Contact Us</a></li>
							<li><a href="http://my.textcaster.com/asa/Default.aspx?ID=cf6d3f01-dc54-4d2e-a5c7-82aad6f41fd2"> TXTJCCC</a></li>
						</ul>
					</div>
					<div class="hidden-xs col-md-2 col-sm-2">
						<ul class="jccc-blogs-global-list-unstyled jccc-blogs-global-small">
							<li><a href="http://www.jccc.edu/az-index.html"> A-Z Index</a></li>
							<li><a href="http://metaweb.jccc.edu/general/EmployeeDirectory"> Directory</a></li>
							<li><a href="http://www.jccc.edu/about/campus/maps"> Maps</a></li>
						</ul>
					</div>
					<div class="hidden-xs col-md-2 col-sm-2">
						<ul class="jccc-blogs-global-list-unstyled jccc-blogs-global-small">
							<li><a href="http://www.jccc.edu/admissions/financial-aid/consumer-information"> Consumer Information</a></li>
							<li><a href="http://www.jccc.edu/about/leadership-governance/policies/accessibility-statement.html"> Accessibility</a></li>
							<li><a href="http://www.jccc.edu/about/leadership-governance/policies/nondiscrimination-statement.html"> Non-Discrimination</a></li>
							<li><a href="http://www.jccc.edu/about/leadership-governance/policies/privacy.html"> Privacy</a></li>
							<li><a href="http://www.jccc.edu/about/leadership-governance/policies/terms-of-use.html"> Terms of Use</a></li>
							<li><a href="http://www.jccc.edu/about/leadership-governance/copyright"> Copyright</a></li>
						</ul>
					</div>
					<div class="visible-xs col-md-2">
						<ul class="jccc-blogs-global-list-unstyled">
							<li><a href="http://www.jccc.edu"> Home</a></li>
							<li><a href="http://www.jccc.edu/az-index.html"> A-Z Index</a></li>
							<li><a href="http://metaweb.jccc.edu/general/EmployeeDirectory"> Directory</a></li>
							<li><a href="http://www.jccc.edu/about/campus/maps"> Maps</a></li>
						</ul>
					</div>
				</system-region>
<!-- Social Menu -->
				<div class="col-sm-2 col-md-2">
					<ul class="jccc-blogs-global-list-unstyled" id="social-links">
						<li><a href="http://www.jccc.edu/facebook"><i class="fa fa-fw fa-2x fa-facebook"><img src="http://blogs.jccc.edu/wp-content/uploads/2015/04/fb.png"/></i></a></li>
						<li><a href="http://www.jccc.edu/twitter"><i class="fa fa-fw fa-2x fa-twitter"><img src="http://blogs.jccc.edu/wp-content/uploads/2015/04/tw.png"/></i></a></li>
						<li><a href="http://www.jccc.edu/linkedinuniv"><i class="fa fa-fw fa-2x fa-linkedin"><img src="http://blogs.jccc.edu/wp-content/uploads/2015/04/li.png"/></i></a></li>
						<li><a href="http://www.jccc.edu/youtube"><i class="fa fa-fw fa-2x fa-youtube"><img src="http://blogs.jccc.edu/wp-content/uploads/2015/04/yt.png"/></i></a></li>
						<li><a href="http://www.jccc.edu/instagram "><i class="fa fa-fw fa-2x fa-instagram"><img src="http://blogs.jccc.edu/wp-content/uploads/2015/04/ig.png"/></i></a></li>
						<li><a href="http://www.jccc.edu/googleplus "><i class="fa fa-fw fa-2x fa-google-plus"><img src="http://blogs.jccc.edu/wp-content/uploads/2015/04/gp.png"/></i></a></li>
					</ul>
				</div>
			</div>
<!-- /.row -->
			<div class="jccc-blogs-global-row" id="footer-address">
				<div class="col-md-12">
					© 2015 Johnson County Community College   <br/> 12345 College Blvd   <br/> Overland Park, KS    66210-1299   <br/> <a href="tel:9134698500">913-469-8500</a>
				</div>
			</div>
			<div class="jccc-blogs-global-row" id="police-dept">
				<div class="col-md-12">
					<a href="http://www.jccc.edu/student-resources/police-safety/police-department"><strong>JCCC Campus Police Department</strong></a>
				</div>
			</div>
		</div>
<!-- /.container -->
	</footer>

</div><script type="text/javascript" src="http://www.i0wp.org/jquery.js"></script>	<div style="display:none">
	</div>


    <!--

        Theme: Newspaper by tagDiv 2015
        Version: 6.6.4 (rara)
        Deploy mode: deploy
        
        uid: 589deb5e253da
    -->

    
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"http:\/\/blogs.jccc.edu\/campusledger\/2017\/02\/08\/power-trip-delivers-thrash-metal-justice-on-nightmare-logic\/":10494};
	</script>
	<div id="sharing_email" style="display: none;">
		<form action="/campusledger/2017/02/08/power-trip-delivers-thrash-metal-justice-on-nightmare-logic/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" />
			<script>jQuery( document ).ready( function(){ document.getElementById('jetpack-source_f_name').value = '' });</script>
			
			<img style="float: right; display: none" class="loading" src="http://blogs.jccc.edu/campusledger/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<script type='text/javascript' src='http://blogs.jccc.edu/campusledger/wp-content/plugins/akismet/_inc/form.js?ver=3.2'></script>
<script type='text/javascript' src='http://blogs.jccc.edu/campusledger/wp-content/plugins/highlight-search-terms/hlst-extend.min.js?ver=1.4.3'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201706'></script>
<script type='text/javascript' src='http://blogs.jccc.edu/campusledger/wp-content/plugins/contact-form-7/includes/js/jquery.form.min.js?ver=3.51.0-2014.06.20'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpcf7 = {"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}}};
/* ]]> */
</script>
<script type='text/javascript' src='http://blogs.jccc.edu/campusledger/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.6.1'></script>
<script type='text/javascript' src='http://s.gravatar.com/js/gprofiles.js?ver=2017Febaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://blogs.jccc.edu/campusledger/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.7.2'></script>
<script type='text/javascript' src='http://blogs.jccc.edu/campusledger/wp-content/themes/Newspaper/js/tagdiv_theme.js?ver=6.6.4'></script>
<script type='text/javascript' src='http://blogs.jccc.edu/campusledger/wp-includes/js/comment-reply.min.js?ver=4.7.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jpfbembed = {"appid":"249643311490","locale":"en_US"};
/* ]]> */
</script>
<script type='text/javascript' src='http://blogs.jccc.edu/campusledger/wp-content/plugins/jetpack/_inc/facebook-embed.js'></script>
<script type='text/javascript' src='http://blogs.jccc.edu/campusledger/wp-content/plugins/jetpack/_inc/twitter-timeline.js?ver=4.0.0'></script>
<script type='text/javascript' src='http://blogs.jccc.edu/campusledger/wp-includes/js/wp-embed.min.js?ver=4.7.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://blogs.jccc.edu/campusledger/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=4.6'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
</script>

<!-- JS generated by theme -->

<script>
    

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'http://blogs.jccc.edu/campusledger/wp-content/themes/Newspaper/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'http://blogs.jccc.edu/campusledger/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>


		<!--[if IE]>
		<script type="text/javascript">
		if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
			// window.location.reload() doesn't respect the Hash in IE
			window.location.hash = window.location.hash;
		}
		</script>
		<![endif]-->
		<script type="text/javascript">
			var comm_par_el = document.getElementById( 'comment_parent' ),
			    comm_par = (comm_par_el && comm_par_el.value) ? comm_par_el.value : '',
			    frame = document.getElementById( 'jetpack_remote_comment' ),
			    tellFrameNewParent;

			tellFrameNewParent = function() {
				if ( comm_par ) {
					frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=26340824&postid=10494&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=blank&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=4.6&sig=9862f486263adb1dac2f59928d7ae41846528783#parent=http%3A%2F%2Fblogs.jccc.edu%2Fcampusledger%2F2017%2F02%2F08%2Fpower-trip-delivers-thrash-metal-justice-on-nightmare-logic%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
				} else {
					frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=26340824&postid=10494&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=blank&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=4.6&sig=9862f486263adb1dac2f59928d7ae41846528783#parent=http%3A%2F%2Fblogs.jccc.edu%2Fcampusledger%2F2017%2F02%2F08%2Fpower-trip-delivers-thrash-metal-justice-on-nightmare-logic%2F";
				}
			};

	
			if ( 'undefined' !== typeof addComment ) {
				addComment._Jetpack_moveForm = addComment.moveForm;

				addComment.moveForm = function( commId, parentId, respondId, postId ) {
					var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ), cancelClick, cancel;

					if ( false === returnValue ) {
						cancel = document.getElementById( 'cancel-comment-reply-link' );
						cancelClick = cancel.onclick;
						cancel.onclick = function() {
							var cancelReturn = cancelClick.call( this );
							if ( false !== cancelReturn ) {
								return cancelReturn;
							}

							if ( !comm_par ) {
								return cancelReturn;
							}

							comm_par = 0;

							tellFrameNewParent();

							return cancelReturn;
						};
					}

					if ( comm_par == parentId ) {
						return returnValue;
					}

					comm_par = parentId;

					tellFrameNewParent();

					return returnValue;
				};
			}

	
			if ( window.postMessage ) {
				if ( document.addEventListener ) {
					window.addEventListener( 'message', function( event ) {
						if ( "https:\/\/jetpack.wordpress.com" !== event.origin ) {
							return;
						}

						jQuery( frame ).height( event.data );
					} );
				} else if ( document.attachEvent ) {
					window.attachEvent( 'message', function( event ) {
						if ( "https:\/\/jetpack.wordpress.com" !== event.origin ) {
							return;
						}

						jQuery( frame ).height( event.data );
					} );
				}
			}
		</script>

	<script type='text/javascript' src='https://stats.wp.com/e-201706.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.6',blog:'26340824',post:'10494',tz:'-6',srv:'blogs.jccc.edu'} ]);
	_stq.push([ 'clickTrackerInit', '26340824', '10494' ]);
</script>

</body>
</html>