<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
    <title>Public education funding across the U.S. needs improvement | The Campus Ledger</title>
    <meta charset="UTF-8" />
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="http://blogs.jccc.edu/campusledger/xmlrpc.php" />
    <meta property="og:image" content="http://blogs.jccc.edu/campusledger/files/2018/02/Margaret-Mellott.jpg" /><meta name="author" content="mmellot1">
<link rel="icon" type="image/png" href="http://blogs.jccc.edu/campusledger/files/2016/03/LedgerLogoSpring16Vectors-03.jpg"><link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Campus Ledger &raquo; Feed" href="http://blogs.jccc.edu/campusledger/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Campus Ledger &raquo; Comments Feed" href="http://blogs.jccc.edu/campusledger/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Campus Ledger &raquo; Public education funding across the U.S. needs improvement Comments Feed" href="http://blogs.jccc.edu/campusledger/2018/03/05/public-education-funding-across-the-u-s-needs-improvement/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/blogs.jccc.edu\/campusledger\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.4"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='colorbox-theme1-css'  href='http://blogs.jccc.edu/campusledger/wp-content/plugins/jquery-lightbox-for-native-galleries/colorbox/theme1/colorbox.css?ver=1.3.14' type='text/css' media='screen' />
<link rel='stylesheet' id='awesome-weather-css'  href='http://blogs.jccc.edu/campusledger/wp-content/plugins/awesome-weather/awesome-weather.css?ver=4.9.4' type='text/css' media='all' />
<style id='awesome-weather-inline-css' type='text/css'>
.awesome-weather-wrap { font-family: 'Open Sans', sans-serif;  font-weight: 400; font-size: 14px; line-height: 14px; } 
</style>
<link rel='stylesheet' id='opensans-googlefont-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C300&#038;ver=4.9.4' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='http://blogs.jccc.edu/campusledger/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.0' type='text/css' media='all' />
<link rel='stylesheet' id='google_font_open_sans-css'  href='http://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C400%2C600%2C700&#038;ver=4.9.4' type='text/css' media='all' />
<link rel='stylesheet' id='google_font_roboto-css'  href='http://fonts.googleapis.com/css?family=Roboto%3A500%2C400italic%2C700%2C500italic%2C400%2C300&#038;ver=4.9.4' type='text/css' media='all' />
<!-- Inline jetpack_facebook_likebox -->
<style id='jetpack_facebook_likebox-inline-css' type='text/css'>
.widget_facebook_likebox {
	overflow: hidden;
}

</style>
<link rel='stylesheet' id='ms-main-css'  href='http://blogs.jccc.edu/campusledger/wp-content/plugins/masterslider/public/assets/css/masterslider.main.css?ver=2.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='ms-custom-css'  href='http://blogs.jccc.edu/campusledger/wp-content/plugins/masterslider/assets/custom.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='js_composer_front-css'  href='http://blogs.jccc.edu/campusledger/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=4.9' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='http://blogs.jccc.edu/campusledger/wp-content/themes/Newspaper/style.css?ver=6.6.4' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='http://blogs.jccc.edu/campusledger/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://blogs.jccc.edu/campusledger/wp-content/plugins/jetpack/css/jetpack.css?ver=5.7.1' type='text/css' media='all' />
<script type='text/javascript' src='http://blogs.jccc.edu/campusledger/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://blogs.jccc.edu/campusledger/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://blogs.jccc.edu/campusledger/wp-content/plugins/jquery-lightbox-for-native-galleries/colorbox/jquery.colorbox-min.js?ver=1.3.14'></script>
<script type='text/javascript' src='http://blogs.jccc.edu/campusledger/wp-content/plugins/wpms-global-content/assets/js/script.js?ver=4.9.4'></script>
<link rel='https://api.w.org/' href='http://blogs.jccc.edu/campusledger/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://blogs.jccc.edu/campusledger/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://blogs.jccc.edu/campusledger/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Industrial Technology Career Fair helps students find employment' href='http://blogs.jccc.edu/campusledger/2018/03/02/industrial-technology-career-fair-helps-students-find-employment/' />
<meta name="generator" content="WordPress 4.9.4" />
<link rel="canonical" href="http://blogs.jccc.edu/campusledger/2018/03/05/public-education-funding-across-the-u-s-needs-improvement/" />
<link rel='shortlink' href='https://wp.me/p1Mws0-36b' />
<link rel="alternate" type="application/json+oembed" href="http://blogs.jccc.edu/campusledger/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fblogs.jccc.edu%2Fcampusledger%2F2018%2F03%2F05%2Fpublic-education-funding-across-the-u-s-needs-improvement%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://blogs.jccc.edu/campusledger/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fblogs.jccc.edu%2Fcampusledger%2F2018%2F03%2F05%2Fpublic-education-funding-across-the-u-s-needs-improvement%2F&#038;format=xml" />

<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//s1.wp.com'/>
<link rel='dns-prefetch' href='//s2.wp.com'/>
<link rel='dns-prefetch' href='//public-api.wordpress.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>
<!--[if lt IE 9]><script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <!-- jQuery Lightbox For Native Galleries v3.2.2 | http://www.viper007bond.com/wordpress-plugins/jquery-lightbox-for-native-galleries/ -->
<script type="text/javascript">
// <![CDATA[
	jQuery(document).ready(function($){
		$(".gallery").each(function(index, obj){
			var galleryid = Math.floor(Math.random()*10000);
			$(obj).find("a").colorbox({rel:galleryid, maxWidth:"95%", maxHeight:"95%"});
		});
		$("a.lightbox").colorbox({maxWidth:"95%", maxHeight:"95%"});
	});
// ]]>
</script>
<meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="http://blogs.jccc.edu/campusledger/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="http://blogs.jccc.edu/campusledger/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]--><script type="text/javascript" src="http://blogs.jccc.edu/campusledger/wp-content/plugins/si-captcha-for-wordpress/captcha/si_captcha.js?ver=1520281008"></script>
<!-- begin SI CAPTCHA Anti-Spam - login/register form style -->
<style type="text/css">
.si_captcha_small { width:175px; height:45px; padding-top:10px; padding-bottom:10px; }
.si_captcha_large { width:250px; height:60px; padding-top:10px; padding-bottom:10px; }
img#si_image_com { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_reg { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_log { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_side_login { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_checkout { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_jetpack { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_bbpress_topic { border-style:none; margin:0; padding-right:5px; float:left; }
.si_captcha_refresh { border-style:none; margin:0; vertical-align:bottom; }
div#si_captcha_input { display:block; padding-top:15px; padding-bottom:5px; }
label#si_captcha_code_label { margin:0; }
input#si_captcha_code_input { width:65px; }
p#si_captcha_code_p { clear: left; padding-top:10px; }
.si-captcha-jetpack-error { color:#DC3232; }
</style>
<!-- end SI CAPTCHA Anti-Spam - login/register form style -->

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Public education funding across the U.S. needs improvement" />
<meta property="og:url" content="http://blogs.jccc.edu/campusledger/2018/03/05/public-education-funding-across-the-u-s-needs-improvement/" />
<meta property="og:description" content="Margaret Mellott Managing editor mmellot1@jccc.edu Everyone goes through the education system at some point in their life. I understand that our country is in debt. I know it’s not easy. Trying to …" />
<meta property="article:published_time" content="2018-03-05T20:14:29+00:00" />
<meta property="article:modified_time" content="2018-03-05T20:14:29+00:00" />
<meta property="og:site_name" content="The Campus Ledger" />
<meta property="og:image" content="http://blogs.jccc.edu/campusledger/files/2018/02/Margaret-Mellott.jpg" />
<meta property="og:image:width" content="4752" />
<meta property="og:image:height" content="3168" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:text:title" content="Public education funding across the U.S. needs improvement" />
<meta name="twitter:image" content="http://blogs.jccc.edu/campusledger/files/2018/02/Margaret-Mellott.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<!-- JS generated by theme -->

<script>
    

var tdBlocksArray = []; //here we store all the items for the current page

//td_block class - each ajax block uses a object of this class for requests
function tdBlock() {
    this.id = '';
    this.block_type = 1; //block type id (1-234 etc)
    this.atts = '';
    this.td_column_number = '';
    this.td_current_page = 1; //
    this.post_count = 0; //from wp
    this.found_posts = 0; //from wp
    this.max_num_pages = 0; //from wp
    this.td_filter_value = ''; //current live filter value
    this.is_ajax_running = false;
    this.td_user_action = ''; // load more or infinite loader (used by the animation)
    this.header_color = '';
    this.ajax_pagination_infinite_stop = ''; //show load more at page x
}

    
    
        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

            if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var tds_smooth_scroll=true;
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var td_ajax_url="https:\/\/blogs.jccc.edu\/campusledger\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=6.6.4";
var td_get_template_directory_uri="http:\/\/blogs.jccc.edu\/campusledger\/wp-content\/themes\/Newspaper";
var tds_snap_menu="smart_snap_mobile";
var tds_logo_on_sticky="";
var tds_header_style="10";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#4db2ec";
var tds_smart_sidebar="";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>

<link rel="icon" href="http://blogs.jccc.edu/campusledger/files/2016/03/cropped-LedgerLogoSpring16Vectors-03-32x32.jpg" sizes="32x32" />
<link rel="icon" href="http://blogs.jccc.edu/campusledger/files/2016/03/cropped-LedgerLogoSpring16Vectors-03-192x192.jpg" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="http://blogs.jccc.edu/campusledger/files/2016/03/cropped-LedgerLogoSpring16Vectors-03-180x180.jpg" />
<meta name="msapplication-TileImage" content="http://blogs.jccc.edu/campusledger/files/2016/03/cropped-LedgerLogoSpring16Vectors-03-270x270.jpg" />
<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head>

<body class="post-template-default single single-post postid-11915 single-format-standard public-education-funding-across-the-u-s-needs-improvement wpb-js-composer js-comp-ver-4.9 vc_responsive td-full-layout" itemscope="itemscope" itemtype="http://schema.org/WebPage">


<div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>

<div id="td-outer-wrap">

    <div class="td-transition-content-and-menu td-mobile-nav-wrap">
        <div id="td-mobile-nav">
    <!-- mobile menu close -->
    <div class="td-mobile-close">
        <a href="#">CLOSE</a>
        <div class="td-nav-triangle"></div>
    </div>

    <div class="td-mobile-content">
        <div class="menu-main-nav-container"><ul id="menu-main-nav" class=""><li id="menu-item-4884" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first menu-item-4884"><a href="http://blogs.jccc.edu/campusledger/news/">News</a></li>
<li id="menu-item-4885" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4885"><a href="http://blogs.jccc.edu/campusledger/features/">Features</a></li>
<li id="menu-item-8920" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8920"><a href="http://blogs.jccc.edu/campusledger/entertainment/">Entertainment</a></li>
<li id="menu-item-4888" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-4888"><a href="http://blogs.jccc.edu/campusledger/sports-2/">Sports</a>
<ul class="sub-menu">
	<li id="menu-item-0" class="menu-item-0"><a href="http://blogs.jccc.edu/campusledger/category/sports/sportsreport/">Cavalier Sports Report</a></li>
</ul>
</li>
<li id="menu-item-4887" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-4887"><a href="http://blogs.jccc.edu/campusledger/opinion/">Opinion</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a href="http://blogs.jccc.edu/campusledger/category/opinion/letter-to-the-editor/">Letter to the Editor</a></li>
</ul>
</li>
<li id="menu-item-4890" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4890"><a href="http://blogs.jccc.edu/campusledger/multimedia/">JCAV-TV</a></li>
<li id="menu-item-8715" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8715"><a href="http://blogs.jccc.edu/ecavradio/">ECAV Radio</a></li>
<li id="menu-item-10931" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10931"><a href="http://blogs.jccc.edu/campusledger/staff/">Staff</a></li>
</ul></div>    </div>
</div>    </div>

        <div class="td-transition-content-and-menu td-content-wrap">



<!--
Header style 10
-->

<div class="td-header-wrap td-header-style-10">

	<div class="td-header-top-menu-full">
		<div class="td-container td-header-row td-header-top-menu">
            
    <div class="top-bar-style-1">
        
<div class="td-header-sp-top-menu">


	<div class="td_data_time">Monday, March 5, 2018</div></div>
        <div class="td-header-sp-top-widget">
    <span class="td-social-icon-wrap"><a target="_blank" href="https://www.facebook.com/CampusLedger/" title="Facebook"><i class="td-icon-font td-icon-facebook"></i></a></span><span class="td-social-icon-wrap"><a target="_blank" href="http://www.twitter.com/campusledger" title="Twitter"><i class="td-icon-font td-icon-twitter"></i></a></span><span class="td-social-icon-wrap"><a target="_blank" href="https://www.youtube.com/user/jcccjcavtv" title="Youtube"><i class="td-icon-font td-icon-youtube"></i></a></span></div>
    </div>

		</div>
	</div>

    <div class="td-banner-wrap-full td-logo-wrap-full">
        <div class="td-header-sp-logo">
            	<a href="http://blogs.jccc.edu/campusledger/">
		<img class="td-retina-data td-logo"  data-retina="http://blogs.jccc.edu/campusledger/files/2016/09/LedgerBannerSpring16-retina-300x99.png" src="http://blogs.jccc.edu/campusledger/files/2016/09/LedgerBannerSpring16.png" alt=""/>
	</a>
        </div>
    </div>

	<div class="td-header-menu-wrap-full">
		<div class="td-header-menu-wrap td-header-gradient">
			<div class="td-container td-header-row td-header-main-menu">
				<div id="td-header-menu">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo">
            <a href="http://blogs.jccc.edu/campusledger/">
        <img class="td-retina-data" data-retina="http://blogs.jccc.edu/campusledger/files/2016/09/LedgerBannerSpring16-retina-300x99.png" src="http://blogs.jccc.edu/campusledger/files/2016/09/LedgerBannerSpring16.png" alt=""/>
    </a>
    </div>
    <div class="menu-main-nav-container"><ul id="menu-main-nav-1" class="sf-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-mega-menu menu-item-4884"><a href="http://blogs.jccc.edu/campusledger/news/">News</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_1_5a9da5b04350e = new tdBlock();
block_td_uid_1_5a9da5b04350e.id = "td_uid_1_5a9da5b04350e";
block_td_uid_1_5a9da5b04350e.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"3","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","class":"td_uid_1_5a9da5b04350e_rand"}';
block_td_uid_1_5a9da5b04350e.td_column_number = "3";
block_td_uid_1_5a9da5b04350e.block_type = "td_block_mega_menu";
block_td_uid_1_5a9da5b04350e.post_count = "5";
block_td_uid_1_5a9da5b04350e.found_posts = "731";
block_td_uid_1_5a9da5b04350e.header_color = "";
block_td_uid_1_5a9da5b04350e.ajax_pagination_infinite_stop = "";
block_td_uid_1_5a9da5b04350e.max_num_pages = "147";
tdBlocksArray.push(block_td_uid_1_5a9da5b04350e);
</script><div class="td_block_wrap td_block_mega_menu td_uid_1_5a9da5b04350e_rand  td-no-subcats td_with_ajax_pagination td-pb-border-top"><div id=td_uid_1_5a9da5b04350e class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2018/03/02/industrial-technology-career-fair-helps-students-find-employment/" rel="bookmark" title="Industrial Technology Career Fair helps students find employment"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2018/03/fair3-218x150.jpg" alt="" title="Industrial Technology Career Fair helps students find employment"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2018/03/02/industrial-technology-career-fair-helps-students-find-employment/" rel="bookmark" title="Industrial Technology Career Fair helps students find employment">Industrial Technology Career Fair helps students find employment</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2018/03/02/the-cav-report-3-2-2018/" rel="bookmark" title="The Cav Report: 3-2-2018"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2018/03/hqdefault-1-218x150.jpg" alt="" title="The Cav Report: 3-2-2018"/><span class="td-video-play-ico"><img width="40" class="td-retina" src="http://blogs.jccc.edu/campusledger/wp-content/themes/Newspaper/images/icons/ico-video-large.png" alt="video"/></span></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2018/03/02/the-cav-report-3-2-2018/" rel="bookmark" title="The Cav Report: 3-2-2018">The Cav Report: 3-2-2018</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2018/02/26/heart-health-month-raises-awareness-encourages-prevention-for-heart-disease/" rel="bookmark" title="Heart Health Month raises awareness, encourages prevention for heart disease"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2018/02/faraed2-218x150.jpg" alt="" title="Heart Health Month raises awareness, encourages prevention for heart disease"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2018/02/26/heart-health-month-raises-awareness-encourages-prevention-for-heart-disease/" rel="bookmark" title="Heart Health Month raises awareness, encourages prevention for heart disease">Heart Health Month raises awareness, encourages prevention for heart disease</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2018/02/23/what-were-working-on-for-next-week/" rel="bookmark" title="What we&#8217;re working on for next week"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2018/01/CL-nameplate-1-218x150.png" alt="" title="What we&#8217;re working on for next week"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2018/02/23/what-were-working-on-for-next-week/" rel="bookmark" title="What we&#8217;re working on for next week">What we&#8217;re working on for next week</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2018/02/19/the-cav-report/" rel="bookmark" title="The Cav Report: 2-16-18"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2018/02/hqdefault-1-218x150.jpg" alt="" title="The Cav Report: 2-16-18"/><span class="td-video-play-ico"><img width="40" class="td-retina" src="http://blogs.jccc.edu/campusledger/wp-content/themes/Newspaper/images/icons/ico-video-large.png" alt="video"/></span></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2018/02/19/the-cav-report/" rel="bookmark" title="The Cav Report: 2-16-18">The Cav Report: 2-16-18</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_1_5a9da5b04350e" data-td_block_id="td_uid_1_5a9da5b04350e"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_1_5a9da5b04350e" data-td_block_id="td_uid_1_5a9da5b04350e"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-mega-menu menu-item-4885"><a href="http://blogs.jccc.edu/campusledger/features/">Features</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_2_5a9da5b046592 = new tdBlock();
block_td_uid_2_5a9da5b046592.id = "td_uid_2_5a9da5b046592";
block_td_uid_2_5a9da5b046592.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"14","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","class":"td_uid_2_5a9da5b046592_rand"}';
block_td_uid_2_5a9da5b046592.td_column_number = "3";
block_td_uid_2_5a9da5b046592.block_type = "td_block_mega_menu";
block_td_uid_2_5a9da5b046592.post_count = "5";
block_td_uid_2_5a9da5b046592.found_posts = "445";
block_td_uid_2_5a9da5b046592.header_color = "";
block_td_uid_2_5a9da5b046592.ajax_pagination_infinite_stop = "";
block_td_uid_2_5a9da5b046592.max_num_pages = "89";
tdBlocksArray.push(block_td_uid_2_5a9da5b046592);
</script><div class="td_block_wrap td_block_mega_menu td_uid_2_5a9da5b046592_rand  td-no-subcats td_with_ajax_pagination td-pb-border-top"><div id=td_uid_2_5a9da5b046592 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2018/02/21/paul-snider-joins-board-of-trustees-after-years-of-community-involvement/" rel="bookmark" title="Paul Snider joins Board of Trustees after years of community involvement"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2018/02/snider-218x150.jpg" alt="" title="Paul Snider joins Board of Trustees after years of community involvement"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2018/02/21/paul-snider-joins-board-of-trustees-after-years-of-community-involvement/" rel="bookmark" title="Paul Snider joins Board of Trustees after years of community involvement">Paul Snider joins Board of Trustees after years of community involvement</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2018/02/15/former-psychologist-joins-board-of-trustees/" rel="bookmark" title="Former therapist joins Board of Trustees"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2018/02/NewBoardMemberCoLab-218x150.png" alt="" title="Former therapist joins Board of Trustees"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2018/02/15/former-psychologist-joins-board-of-trustees/" rel="bookmark" title="Former therapist joins Board of Trustees">Former therapist joins Board of Trustees</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2018/02/14/seven-affordable-activities-to-do-this-valentines-day/" rel="bookmark" title="Seven affordable activities to do this Valentine’s Day"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2018/02/KennaHeartPhoto_MG_1003-218x150.jpg" alt="" title="Seven affordable activities to do this Valentine’s Day"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2018/02/14/seven-affordable-activities-to-do-this-valentines-day/" rel="bookmark" title="Seven affordable activities to do this Valentine’s Day">Seven affordable activities to do this Valentine’s Day</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2018/02/02/spring-student-concert-series-auditions/" rel="bookmark" title="Spring student concert series auditions"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2018/02/maxresdefault-1-218x150.jpg" alt="" title="Spring student concert series auditions"/><span class="td-video-play-ico"><img width="40" class="td-retina" src="http://blogs.jccc.edu/campusledger/wp-content/themes/Newspaper/images/icons/ico-video-large.png" alt="video"/></span></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2018/02/02/spring-student-concert-series-auditions/" rel="bookmark" title="Spring student concert series auditions">Spring student concert series auditions</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2018/01/25/nursing-professors-give-insight-to-the-increasing-number-of-flu-diagnoses/" rel="bookmark" title="Nursing professors give insight to the increasing number of flu diagnoses"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2018/01/Screen-Shot-2018-01-25-at-7.35.14-PM-218x150.png" alt="" title="Nursing professors give insight to the increasing number of flu diagnoses"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2018/01/25/nursing-professors-give-insight-to-the-increasing-number-of-flu-diagnoses/" rel="bookmark" title="Nursing professors give insight to the increasing number of flu diagnoses">Nursing professors give insight to the increasing number of flu diagnoses</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_2_5a9da5b046592" data-td_block_id="td_uid_2_5a9da5b046592"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_2_5a9da5b046592" data-td_block_id="td_uid_2_5a9da5b046592"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-mega-menu menu-item-8920"><a href="http://blogs.jccc.edu/campusledger/entertainment/">Entertainment</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_3_5a9da5b048ff3 = new tdBlock();
block_td_uid_3_5a9da5b048ff3.id = "td_uid_3_5a9da5b048ff3";
block_td_uid_3_5a9da5b048ff3.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"2098","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","class":"td_uid_3_5a9da5b048ff3_rand"}';
block_td_uid_3_5a9da5b048ff3.td_column_number = "3";
block_td_uid_3_5a9da5b048ff3.block_type = "td_block_mega_menu";
block_td_uid_3_5a9da5b048ff3.post_count = "5";
block_td_uid_3_5a9da5b048ff3.found_posts = "77";
block_td_uid_3_5a9da5b048ff3.header_color = "";
block_td_uid_3_5a9da5b048ff3.ajax_pagination_infinite_stop = "";
block_td_uid_3_5a9da5b048ff3.max_num_pages = "16";
tdBlocksArray.push(block_td_uid_3_5a9da5b048ff3);
</script><div class="td_block_wrap td_block_mega_menu td_uid_3_5a9da5b048ff3_rand  td-no-subcats td_with_ajax_pagination td-pb-border-top"><div id=td_uid_3_5a9da5b048ff3 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2018/01/23/movie-review-hokey-dialogue-and-ancient-devices-are-no-match-for-a-good-story-by-your-side/" rel="bookmark" title="Movie review: It&#8217;s time for the series to end"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2018/01/Fandango-FanShop-Exclusive-Star-Wars-Poster-sm-Copy-218x150.jpg" alt="" title="Movie review: It&#8217;s time for the series to end"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2018/01/23/movie-review-hokey-dialogue-and-ancient-devices-are-no-match-for-a-good-story-by-your-side/" rel="bookmark" title="Movie review: It&#8217;s time for the series to end">Movie review: It&#8217;s time for the series to end</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2017/09/28/movie-review-the-lego-ninjago-movie-not-the-best-brick-in-the-set/" rel="bookmark" title="Movie review: “The LEGO Ninjago Movie” not the best brick in the set"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2017/09/promo328921455-218x150.jpg" alt="" title="Movie review: “The LEGO Ninjago Movie” not the best brick in the set"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2017/09/28/movie-review-the-lego-ninjago-movie-not-the-best-brick-in-the-set/" rel="bookmark" title="Movie review: “The LEGO Ninjago Movie” not the best brick in the set">Movie review: “The LEGO Ninjago Movie” not the best brick in&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2017/09/18/movie-review-in-a-year-of-mediocre-blockbusters-it-floats-to-the-top/" rel="bookmark" title="Movie review: In a year of mediocre blockbusters, “IT” floats to the top"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2017/09/It_poster-218x150.jpg" alt="" title="Movie review: In a year of mediocre blockbusters, “IT” floats to the top"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2017/09/18/movie-review-in-a-year-of-mediocre-blockbusters-it-floats-to-the-top/" rel="bookmark" title="Movie review: In a year of mediocre blockbusters, “IT” floats to the top">Movie review: In a year of mediocre blockbusters, “IT” floats to&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2017/04/06/movie-review-beauty-and-the-beast-adaption-bursting-with-disney-magic-despite-wrinkles/" rel="bookmark" title="Movie review: &#8220;Beauty and the Beast&#8221; adaption bursting with Disney magic despite wrinkles"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2017/04/eu_batb_flex-hero_header_r_430eac8d-218x150.jpeg" alt="" title="Movie review: &#8220;Beauty and the Beast&#8221; adaption bursting with Disney magic despite wrinkles"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2017/04/06/movie-review-beauty-and-the-beast-adaption-bursting-with-disney-magic-despite-wrinkles/" rel="bookmark" title="Movie review: &#8220;Beauty and the Beast&#8221; adaption bursting with Disney magic despite wrinkles">Movie review: &#8220;Beauty and the Beast&#8221; adaption bursting with Disney magic&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2017/02/11/anticipate-big-battles-on-a-new-season-of-the-walking-dead/" rel="bookmark" title="Anticipate big battles on the return of &#8220;The Walking Dead&#8221;"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2017/02/Walking-Dead-218x150.jpg" alt="" title="Anticipate big battles on the return of &#8220;The Walking Dead&#8221;"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2017/02/11/anticipate-big-battles-on-a-new-season-of-the-walking-dead/" rel="bookmark" title="Anticipate big battles on the return of &#8220;The Walking Dead&#8221;">Anticipate big battles on the return of &#8220;The Walking Dead&#8221;</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_3_5a9da5b048ff3" data-td_block_id="td_uid_3_5a9da5b048ff3"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_3_5a9da5b048ff3" data-td_block_id="td_uid_3_5a9da5b048ff3"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-mega-menu menu-item-4888"><a href="http://blogs.jccc.edu/campusledger/sports-2/">Sports</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_4_5a9da5b04be71 = new tdBlock();
block_td_uid_4_5a9da5b04be71.id = "td_uid_4_5a9da5b04be71";
block_td_uid_4_5a9da5b04be71.atts = '{"limit":4,"td_column_number":3,"ajax_pagination":"next_prev","category_id":"16","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","class":"td_uid_4_5a9da5b04be71_rand"}';
block_td_uid_4_5a9da5b04be71.td_column_number = "3";
block_td_uid_4_5a9da5b04be71.block_type = "td_block_mega_menu";
block_td_uid_4_5a9da5b04be71.post_count = "4";
block_td_uid_4_5a9da5b04be71.found_posts = "341";
block_td_uid_4_5a9da5b04be71.header_color = "";
block_td_uid_4_5a9da5b04be71.ajax_pagination_infinite_stop = "";
block_td_uid_4_5a9da5b04be71.max_num_pages = "86";
tdBlocksArray.push(block_td_uid_4_5a9da5b04be71);
</script>            <script>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</script>
            <div class="td_block_wrap td_block_mega_menu td_uid_4_5a9da5b04be71_rand  td_with_ajax_pagination td-pb-border-top"><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_4_5a9da5b04be71" id="td_uid_5_5a9da5b04cb75" data-td_block_id="td_uid_4_5a9da5b04be71" data-td_filter_value="" href="http://blogs.jccc.edu/campusledger/category/sports/">All</a><a class="mega-menu-sub-cat-td_uid_4_5a9da5b04be71"  id="td_uid_6_5a9da5b04cc4b" data-td_block_id="td_uid_4_5a9da5b04be71" data-td_filter_value="2107" href="http://blogs.jccc.edu/campusledger/category/sports/sportsreport/">Cavalier Sports Report</a></div></div><div id=td_uid_4_5a9da5b04be71 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2018/02/16/new-players-same-successful-story-for-womens-basketball/" rel="bookmark" title="New players, same successful story for women’s basketball"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2018/02/Cerena-Reeves-218x150.jpg" alt="" title="New players, same successful story for women’s basketball"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2018/02/16/new-players-same-successful-story-for-womens-basketball/" rel="bookmark" title="New players, same successful story for women’s basketball">New players, same successful story for women’s basketball</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2018/02/09/veteran-players-lead-mens-basketball-during-winning-streak/" rel="bookmark" title="Veteran players lead men’s basketball during winning streak"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2018/02/Copy-of-IMG_5738-218x150.jpg" alt="" title="Veteran players lead men’s basketball during winning streak"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2018/02/09/veteran-players-lead-mens-basketball-during-winning-streak/" rel="bookmark" title="Veteran players lead men’s basketball during winning streak">Veteran players lead men’s basketball during winning streak</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2018/02/07/amidst-numerous-injuries-mens-baseball-returns-for-a-new-season/" rel="bookmark" title="Amidst numerous injuries, men’s baseball returns for a new season"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2018/02/tee-218x150.jpg" alt="" title="Amidst numerous injuries, men’s baseball returns for a new season"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2018/02/07/amidst-numerous-injuries-mens-baseball-returns-for-a-new-season/" rel="bookmark" title="Amidst numerous injuries, men’s baseball returns for a new season">Amidst numerous injuries, men’s baseball returns for a new season</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2018/01/30/alumni-work-to-save-track-unite-community/" rel="bookmark" title="Alumni work to save track, unite community"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2018/01/track-edit-1-218x150.jpg" alt="" title="Alumni work to save track, unite community"/><span class="td-video-play-ico"><img width="40" class="td-retina" src="http://blogs.jccc.edu/campusledger/wp-content/themes/Newspaper/images/icons/ico-video-large.png" alt="video"/></span></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2018/01/30/alumni-work-to-save-track-unite-community/" rel="bookmark" title="Alumni work to save track, unite community">Alumni work to save track, unite community</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_4_5a9da5b04be71" data-td_block_id="td_uid_4_5a9da5b04be71"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_4_5a9da5b04be71" data-td_block_id="td_uid_4_5a9da5b04be71"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-mega-menu menu-item-4887"><a href="http://blogs.jccc.edu/campusledger/opinion/">Opinion</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_7_5a9da5b0531f0 = new tdBlock();
block_td_uid_7_5a9da5b0531f0.id = "td_uid_7_5a9da5b0531f0";
block_td_uid_7_5a9da5b0531f0.atts = '{"limit":4,"td_column_number":3,"ajax_pagination":"next_prev","category_id":"8","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","class":"td_uid_7_5a9da5b0531f0_rand"}';
block_td_uid_7_5a9da5b0531f0.td_column_number = "3";
block_td_uid_7_5a9da5b0531f0.block_type = "td_block_mega_menu";
block_td_uid_7_5a9da5b0531f0.post_count = "4";
block_td_uid_7_5a9da5b0531f0.found_posts = "293";
block_td_uid_7_5a9da5b0531f0.header_color = "";
block_td_uid_7_5a9da5b0531f0.ajax_pagination_infinite_stop = "";
block_td_uid_7_5a9da5b0531f0.max_num_pages = "74";
tdBlocksArray.push(block_td_uid_7_5a9da5b0531f0);
</script>            <script>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</script>
            <div class="td_block_wrap td_block_mega_menu td_uid_7_5a9da5b0531f0_rand  td_with_ajax_pagination td-pb-border-top"><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_7_5a9da5b0531f0" id="td_uid_8_5a9da5b0542a6" data-td_block_id="td_uid_7_5a9da5b0531f0" data-td_filter_value="" href="http://blogs.jccc.edu/campusledger/category/opinion/">All</a><a class="mega-menu-sub-cat-td_uid_7_5a9da5b0531f0"  id="td_uid_9_5a9da5b054381" data-td_block_id="td_uid_7_5a9da5b0531f0" data-td_filter_value="2104" href="http://blogs.jccc.edu/campusledger/category/opinion/letter-to-the-editor/">Letter to the Editor</a></div></div><div id=td_uid_7_5a9da5b0531f0 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2018/03/05/public-education-funding-across-the-u-s-needs-improvement/" rel="bookmark" title="Public education funding across the U.S. needs improvement"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2018/02/Margaret-Mellott-218x150.jpg" alt="" title="Public education funding across the U.S. needs improvement"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2018/03/05/public-education-funding-across-the-u-s-needs-improvement/" rel="bookmark" title="Public education funding across the U.S. needs improvement">Public education funding across the U.S. needs improvement</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2018/03/02/a-look-at-2017s-best-picture-nominees/" rel="bookmark" title="A look at 2017’s best picture nominees"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2018/03/oscars_cover-218x150.jpg" alt="" title="A look at 2017’s best picture nominees"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2018/03/02/a-look-at-2017s-best-picture-nominees/" rel="bookmark" title="A look at 2017’s best picture nominees">A look at 2017’s best picture nominees</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2018/02/27/column-u-s-must-move-closer-to-the-standard-of-europe-on-abortion/" rel="bookmark" title="Column: U.S. must move closer to the standard of Europe on abortion"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2018/02/Pete-Loganbill-218x150.jpg" alt="" title="Column: U.S. must move closer to the standard of Europe on abortion"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2018/02/27/column-u-s-must-move-closer-to-the-standard-of-europe-on-abortion/" rel="bookmark" title="Column: U.S. must move closer to the standard of Europe on abortion">Column: U.S. must move closer to the standard of Europe on&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2018/02/19/column-our-past-is-our-future-if-we-forget/" rel="bookmark" title="Column: Our past is our future if we forget"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2018/02/Margaret-Mellott-218x150.jpg" alt="" title="Column: Our past is our future if we forget"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2018/02/19/column-our-past-is-our-future-if-we-forget/" rel="bookmark" title="Column: Our past is our future if we forget">Column: Our past is our future if we forget</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_7_5a9da5b0531f0" data-td_block_id="td_uid_7_5a9da5b0531f0"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_7_5a9da5b0531f0" data-td_block_id="td_uid_7_5a9da5b0531f0"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-mega-menu menu-item-4890"><a href="http://blogs.jccc.edu/campusledger/multimedia/">JCAV-TV</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_10_5a9da5b058a5b = new tdBlock();
block_td_uid_10_5a9da5b058a5b.id = "td_uid_10_5a9da5b058a5b";
block_td_uid_10_5a9da5b058a5b.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"2097","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","class":"td_uid_10_5a9da5b058a5b_rand"}';
block_td_uid_10_5a9da5b058a5b.td_column_number = "3";
block_td_uid_10_5a9da5b058a5b.block_type = "td_block_mega_menu";
block_td_uid_10_5a9da5b058a5b.post_count = "5";
block_td_uid_10_5a9da5b058a5b.found_posts = "134";
block_td_uid_10_5a9da5b058a5b.header_color = "";
block_td_uid_10_5a9da5b058a5b.ajax_pagination_infinite_stop = "";
block_td_uid_10_5a9da5b058a5b.max_num_pages = "27";
tdBlocksArray.push(block_td_uid_10_5a9da5b058a5b);
</script><div class="td_block_wrap td_block_mega_menu td_uid_10_5a9da5b058a5b_rand  td-no-subcats td_with_ajax_pagination td-pb-border-top"><div id=td_uid_10_5a9da5b058a5b class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2017/12/13/quartet-winter-concert/" rel="bookmark" title="Quartet Winter Concert"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2017/12/hqdefault-1-218x150.jpg" alt="" title="Quartet Winter Concert"/><span class="td-video-play-ico"><img width="40" class="td-retina" src="http://blogs.jccc.edu/campusledger/wp-content/themes/Newspaper/images/icons/ico-video-large.png" alt="video"/></span></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2017/12/13/quartet-winter-concert/" rel="bookmark" title="Quartet Winter Concert">Quartet Winter Concert</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2017/12/05/holiday-reacts/" rel="bookmark" title="Holiday Reacts"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2017/12/maxresdefault-4-218x150.jpg" alt="" title="Holiday Reacts"/><span class="td-video-play-ico"><img width="40" class="td-retina" src="http://blogs.jccc.edu/campusledger/wp-content/themes/Newspaper/images/icons/ico-video-large.png" alt="video"/></span></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2017/12/05/holiday-reacts/" rel="bookmark" title="Holiday Reacts">Holiday Reacts</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2017/12/05/the-cav-report-11-30-17/" rel="bookmark" title="The Cav Report: 11- 30-17"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2017/12/maxresdefault-1-218x150.jpg" alt="" title="The Cav Report: 11- 30-17"/><span class="td-video-play-ico"><img width="40" class="td-retina" src="http://blogs.jccc.edu/campusledger/wp-content/themes/Newspaper/images/icons/ico-video-large.png" alt="video"/></span></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2017/12/05/the-cav-report-11-30-17/" rel="bookmark" title="The Cav Report: 11- 30-17">The Cav Report: 11- 30-17</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2017/11/29/jcav-visits-midland-holiday-pines-tree-farm/" rel="bookmark" title="JCAV visits Midland Holiday Pines Tree Farm"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2017/11/maxresdefault-25-218x150.jpg" alt="" title="JCAV visits Midland Holiday Pines Tree Farm"/><span class="td-video-play-ico"><img width="40" class="td-retina" src="http://blogs.jccc.edu/campusledger/wp-content/themes/Newspaper/images/icons/ico-video-large.png" alt="video"/></span></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2017/11/29/jcav-visits-midland-holiday-pines-tree-farm/" rel="bookmark" title="JCAV visits Midland Holiday Pines Tree Farm">JCAV visits Midland Holiday Pines Tree Farm</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2017/11/28/great-books-series-in-cold-blood/" rel="bookmark" title="Great Books Series: In Cold Blood"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2017/11/maxresdefault-21-218x150.jpg" alt="" title="Great Books Series: In Cold Blood"/><span class="td-video-play-ico"><img width="40" class="td-retina" src="http://blogs.jccc.edu/campusledger/wp-content/themes/Newspaper/images/icons/ico-video-large.png" alt="video"/></span></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2017/11/28/great-books-series-in-cold-blood/" rel="bookmark" title="Great Books Series: In Cold Blood">Great Books Series: In Cold Blood</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_10_5a9da5b058a5b" data-td_block_id="td_uid_10_5a9da5b058a5b"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_10_5a9da5b058a5b" data-td_block_id="td_uid_10_5a9da5b058a5b"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-8715"><a href="http://blogs.jccc.edu/ecavradio/">ECAV Radio</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-10931"><a href="http://blogs.jccc.edu/campusledger/staff/">Staff</a></li>
</ul></div></div>


<div class="td-search-wrapper">
    <div id="td-top-search">
        <!-- Search -->
        <div class="header-search-wrap">
            <div class="dropdown header-search">
                <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            </div>
        </div>
    </div>
</div>

<div class="header-search-wrap">
	<div class="dropdown header-search">
		<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
			<form role="search" method="get" class="td-search-form" action="http://blogs.jccc.edu/campusledger/">
				<div class="td-head-form-search-wrap">
					<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
				</div>
			</form>
			<div id="td-aj-search"></div>
		</div>
	</div>
</div>			</div>
		</div>
	</div>

    <div class="td-banner-wrap-full td-banner-bg">
        <div class="td-container-header td-header-row td-header-header">
            <div class="td-header-sp-recs">
                <div class="td-header-rec-wrap">
    <div class="td-a-rec td-a-rec-id-header "><a href="" target="_blank"><img src=""></a>

</div>
</div>            </div>
        </div>
    </div>

</div><div class="td-main-content-wrap">

    <div class="td-container td-post-template-default ">
        <div class="td-crumb-container"><div class="entry-crumbs"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="" class="entry-crumb" itemprop="url" href="http://blogs.jccc.edu/campusledger/"><span itemprop="title">Home</span></a></span> <i class="td-icon-right td-bread-sep"></i> <span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="View all posts in Opinion" class="entry-crumb" itemprop="url" href="http://blogs.jccc.edu/campusledger/category/opinion/"><span itemprop="title">Opinion</span></a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last" itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><meta itemprop="title" content = "Public education funding across the U.S. needs improvement"><meta itemprop="url" content = "http://blogs.jccc.edu/campusledger/2018/03/05/public-education-funding-across-the-u-s-needs-improvement/">Public education funding across the U.S. needs improvement</span></div></div>

        <div class="td-pb-row">
                                    <div class="td-pb-span8 td-main-content" role="main">
                            <div class="td-ss-main-content">
                                
    <article id="post-11915" class="post-11915 post type-post status-publish format-standard has-post-thumbnail hentry category-opinion" itemscope itemtype="http://schema.org/Article">
        <div class="td-post-header">

            <ul class="td-category"><li class="entry-category"><a  href="http://blogs.jccc.edu/campusledger/category/opinion/">Opinion</a></li></ul>
            <header class="td-post-title">
                <h1 class="entry-title">Public education funding across the U.S. needs improvement</h1>

                

                <div class="td-module-meta-info">
                                        <div class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-03-05T14:14:29+00:00" >March 5, 2018</time></div>                    <div class="td-post-comments"><a href="http://blogs.jccc.edu/campusledger/2018/03/05/public-education-funding-across-the-u-s-needs-improvement/#respond"><i class="td-icon-comments"></i>0</a></div>                                    </div>

            </header>

        </div>

        <div class="td-post-sharing td-post-sharing-top ">
				<div class="td-default-sharing">
		            <a class="td-social-sharing-buttons td-social-facebook" href="http://www.facebook.com/sharer.php?u=http%3A%2F%2Fblogs.jccc.edu%2Fcampusledger%2F2018%2F03%2F05%2Fpublic-education-funding-across-the-u-s-needs-improvement%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-facebook"></i><div class="td-social-but-text">Share on Facebook</div></a>
		            <a class="td-social-sharing-buttons td-social-twitter" href="https://twitter.com/intent/tweet?text=Public+education+funding+across+the+U.S.+needs+improvement&url=http%3A%2F%2Fblogs.jccc.edu%2Fcampusledger%2F2018%2F03%2F05%2Fpublic-education-funding-across-the-u-s-needs-improvement%2F&via=campusledger"  ><i class="td-icon-twitter"></i><div class="td-social-but-text">Tweet on Twitter</div></a>
		            <a class="td-social-sharing-buttons td-social-google" href="http://plus.google.com/share?url=http://blogs.jccc.edu/campusledger/2018/03/05/public-education-funding-across-the-u-s-needs-improvement/" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-googleplus"></i></a>
		            <a class="td-social-sharing-buttons td-social-pinterest" href="http://pinterest.com/pin/create/button/?url=http://blogs.jccc.edu/campusledger/2018/03/05/public-education-funding-across-the-u-s-needs-improvement/&amp;media=http://blogs.jccc.edu/campusledger/files/2018/02/Margaret-Mellott.jpg&description=Public+education+funding+across+the+U.S.+needs+improvement" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-pinterest"></i></a>
		            <a class="td-social-sharing-buttons td-social-whatsapp" href="whatsapp://send?text=Public+education+funding+across+the+U.S.+needs+improvement - http%3A%2F%2Fblogs.jccc.edu%2Fcampusledger%2F2018%2F03%2F05%2Fpublic-education-funding-across-the-u-s-needs-improvement%2F" ><i class="td-icon-whatsapp"></i></a>
	            </div></div>

        <div class="td-post-content">

        <div class="td-post-featured-image"><a href="http://blogs.jccc.edu/campusledger/files/2018/02/Margaret-Mellott.jpg" data-caption=""><img width="696" height="464" class="entry-thumb td-modal-image" src="http://blogs.jccc.edu/campusledger/files/2018/02/Margaret-Mellott-696x464.jpg" alt="" title=""/></a></div>
        <p><strong>Margaret Mellott</strong></p>
<p><strong>Managing editor</strong></p>
<p><em>mmellot1@jccc.edu</em></p>
<p>Everyone goes through the education system at some point in their life.</p>
<div class="td-a-rec td-a-rec-id-content_inlineright "><a href="" target="_blank"><img src=""></a></div><p>I understand that our country is in debt. I know it’s not easy. Trying to figure out funding isn’t easy. I know that, but shouldn’t educating our children be one of our top priorities? Since the crash in 2008, we are still trying to reach the amount of funding we had before. However, it feels like with every chance there is, the government cuts funding.</p>
<p>Why is this? Where do our priorities lie?</p>
<p>So, what exactly does funding for education do? It’s more than getting new textbooks, raising teachers salary, and providing the different clubs and organizations with the money they need to exist. It’s about providing for and protecting our children.</p>
<p><strong>Education funding</strong></p>
<p>In a series of tweets from Kris W. Kobach, Kansas Secretary of State, he said “Throwing money at school’s doesn’t work! Doing the same thing over and over again isn’t the solution. We must spend money where it counts and tell the courts to get out of our way. #ksgop #ksleg</p>
<p>“I went to Washburn Rural High School in Topeka. We used beat up textbooks and held classes in a single-wide mobile home in the parking lot. Somehow I made it into Harvard. It didn’t hurt my education! #ksleg #ksgop18”</p>
<p>I responded by quote tweeting him a few things, but the most important is “Do you not understand that other, much less privileged kids — that are much smarter than you — can’t even make it past HS graduation because of the circumstances they’re in? If public education was in better shape, we could give students the resources they need to graduate.”</p>
<p>Of course I understand that a lot of the problems won’t be solved with money. However, a big step in improving education would be to just stop cutting funding. The children in this country are our future presidents, congressmen, doctors, teachers and other just as important jobs. Why isn’t their education a priority?</p>
<p>The one issue I hear the most has to do with taxation. Some people only want their taxes to go to something that directly benefits them. While I can understand it with certain, less direct taxes, I don’t when it comes to education.</p>
<p>Everyone has ties to education. We all went to school, our parents went to school, and one day, our children will go to school. How could you not want the best for the children in the country, because one day, it will directly impact you.</p>
<p>I’m not alone in the belief that the U.S. education system is in need of help. In a <a href="http://www.pewresearch.org/fact-tank/2013/08/13/many-americans-say-educational-system-in-need-of-overhaul/">study done by the Pew Research Center</a>, 66 percent say the education system either needs to be completely rebuilt (21 percent) or that it needs major changes (45 percent).</p>
<p>Education is so, so important. We need to be doing more.</p>
<p><strong>Security funding</strong></p>
<p>This isn’t a column about gun control, but it needs to be addressed. This is about making the effort to better protect the children in public schools. We can do that by adding more the education budget.</p>
<p>In proposed bill HR 18-06 and SPB 7026 for Florida, it suggests that <a href="http://www.miamiherald.com/news/politics-government/state-politics/article202360759.html">$67 million</a> be put towards a “school marshal” program to train teachers to carry guns. In a <a href="https://www.cnn.com/2013/02/27/politics/teacher-guns-survey/index.html">study done by CNN</a>, three-fourths of teachers in the nation would not want to carry a gun. If teachers don’t want to carry guns, the $67 million could be used to better improve the education system.</p>
<p>With better funding, we could find security alternatives that will help prevent these school shootings. Maybe it’s employing counselors that do more than just help with college applications. Maybe it’s providing better education on mental health in classes. Maybe it’s better training for teachers regarding “red-flag” students. I don’t have all the answers, but at least I’m trying.</p>
<p>Most of the time in politics, people get caught up with only saying “no” to certain things. If you want to shoot down an idea, you should always have another suggestion. If you can’t decide between two ideas, try to come up with other solutions. People get so stuck on one thing or the other and it’s frustrating. It’s not that difficult to come together and work on something, especially if it’s something that everyone has a tie to, like education.</p>
<p>The education system is failing our students. The goal should be provide kids with the best and safest learning environments. Better funding is going to do more than provide textbooks, it will give students the resources they need to succeed. As a country, our children’s education should be a number one priority; let’s get there.</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-11915" class="share-facebook sd-button share-icon no-text" href="http://blogs.jccc.edu/campusledger/2018/03/05/public-education-funding-across-the-u-s-needs-improvement/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-11915" class="share-twitter sd-button share-icon no-text" href="http://blogs.jccc.edu/campusledger/2018/03/05/public-education-funding-across-the-u-s-needs-improvement/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button share-icon no-text" href="http://blogs.jccc.edu/campusledger/2018/03/05/public-education-funding-across-the-u-s-needs-improvement/?share=email" target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-11915" class="share-google-plus-1 sd-button share-icon no-text" href="http://blogs.jccc.edu/campusledger/2018/03/05/public-education-funding-across-the-u-s-needs-improvement/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span></span><span class="sharing-screen-reader-text">Click to share on Google+ (Opens in new window)</span></a></li><li class="share-print"><a rel="nofollow" data-shared="" class="share-print sd-button share-icon no-text" href="http://blogs.jccc.edu/campusledger/2018/03/05/public-education-funding-across-the-u-s-needs-improvement/#print" target="_blank" title="Click to print"><span></span><span class="sharing-screen-reader-text">Click to print (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon no-text" href="http://blogs.jccc.edu/campusledger/2018/03/05/public-education-funding-across-the-u-s-needs-improvement/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li><a href="#" class="sharing-anchor sd-button share-more"><span>More</span></a></li><li class="share-end"></li></ul><div class="sharing-hidden"><div class="inner" style="display: none;width:150px;"><ul style="background-image:none;"><li class="share-linkedin"><a rel="nofollow" data-shared="sharing-linkedin-11915" class="share-linkedin sd-button share-icon no-text" href="http://blogs.jccc.edu/campusledger/2018/03/05/public-education-funding-across-the-u-s-needs-improvement/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div></div></div>        </div>


        <footer>
                        
            <div class="td-post-source-tags">
                                            </div>

            <div class="td-post-sharing td-post-sharing-bottom td-with-like"><span class="td-post-share-title">SHARE</span>
            <div class="td-default-sharing">
	            <a class="td-social-sharing-buttons td-social-facebook" href="http://www.facebook.com/sharer.php?u=http%3A%2F%2Fblogs.jccc.edu%2Fcampusledger%2F2018%2F03%2F05%2Fpublic-education-funding-across-the-u-s-needs-improvement%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-facebook"></i><div class="td-social-but-text">Facebook</div></a>
	            <a class="td-social-sharing-buttons td-social-twitter" href="https://twitter.com/intent/tweet?text=Public+education+funding+across+the+U.S.+needs+improvement&url=http%3A%2F%2Fblogs.jccc.edu%2Fcampusledger%2F2018%2F03%2F05%2Fpublic-education-funding-across-the-u-s-needs-improvement%2F&via=campusledger"><i class="td-icon-twitter"></i><div class="td-social-but-text">Twitter</div></a>
	            <a class="td-social-sharing-buttons td-social-google" href="http://plus.google.com/share?url=http://blogs.jccc.edu/campusledger/2018/03/05/public-education-funding-across-the-u-s-needs-improvement/" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-googleplus"></i></a>
	            <a class="td-social-sharing-buttons td-social-pinterest" href="http://pinterest.com/pin/create/button/?url=http://blogs.jccc.edu/campusledger/2018/03/05/public-education-funding-across-the-u-s-needs-improvement/&amp;media=http://blogs.jccc.edu/campusledger/files/2018/02/Margaret-Mellott.jpg&description=Public+education+funding+across+the+U.S.+needs+improvement" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-pinterest"></i></a>
	            <a class="td-social-sharing-buttons td-social-whatsapp" href="whatsapp://send?text=Public+education+funding+across+the+U.S.+needs+improvement - http%3A%2F%2Fblogs.jccc.edu%2Fcampusledger%2F2018%2F03%2F05%2Fpublic-education-funding-across-the-u-s-needs-improvement%2F" ><i class="td-icon-whatsapp"></i></a>
            </div><div class="td-classic-sharing"><ul><li class="td-classic-facebook"><iframe frameBorder="0" src="http://www.facebook.com/plugins/like.php?href=http://blogs.jccc.edu/campusledger/2018/03/05/public-education-funding-across-the-u-s-needs-improvement/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:105px; height:21px; background-color:transparent;"></iframe></li><li class="td-classic-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="http://blogs.jccc.edu/campusledger/2018/03/05/public-education-funding-across-the-u-s-needs-improvement/" data-text="Public education funding across the U.S. needs improvement" data-via="" data-lang="en">tweet</a> <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></li></ul></div></div>            <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="http://blogs.jccc.edu/campusledger/2018/03/02/industrial-technology-career-fair-helps-students-find-employment/">Industrial Technology Career Fair helps students find employment</a></div></div><div class="td-next-prev-separator"></div></div>            <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="http://blogs.jccc.edu/campusledger/author/mmellot1/">mmellot1</a></span></div>	        <span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="mmellot1"></span><meta itemprop="datePublished" content="2018-03-05T14:14:29+00:00"><meta itemprop="dateModified" content="2018-03-05T14:14:29+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="http://blogs.jccc.edu/campusledger/2018/03/05/public-education-funding-across-the-u-s-needs-improvement/"/><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://blogs.jccc.edu/campusledger/files/2016/09/LedgerBannerSpring16.png"></span><meta itemprop="name" content="The Campus Ledger"></span><meta itemprop="headline " content="Public education funding across the U.S. needs improvement"><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://blogs.jccc.edu/campusledger/files/2018/02/Margaret-Mellott.jpg"><meta itemprop="width" content="4752"><meta itemprop="height" content="3168"></span>        </footer>

    </article> <!-- /.post -->

    <script>var block_td_uid_11_5a9da5b060aca = new tdBlock();
block_td_uid_11_5a9da5b060aca.id = "td_uid_11_5a9da5b060aca";
block_td_uid_11_5a9da5b060aca.atts = '{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"td_uid_11_5a9da5b060aca_rand","td_column_number":3,"live_filter_cur_post_id":11915,"live_filter_cur_post_author":"864"}';
block_td_uid_11_5a9da5b060aca.td_column_number = "3";
block_td_uid_11_5a9da5b060aca.block_type = "td_block_related_posts";
block_td_uid_11_5a9da5b060aca.post_count = "3";
block_td_uid_11_5a9da5b060aca.found_posts = "290";
block_td_uid_11_5a9da5b060aca.header_color = "";
block_td_uid_11_5a9da5b060aca.ajax_pagination_infinite_stop = "";
block_td_uid_11_5a9da5b060aca.max_num_pages = "97";
tdBlocksArray.push(block_td_uid_11_5a9da5b060aca);
</script><div class="td_block_wrap td_block_related_posts td_uid_11_5a9da5b060aca_rand td_with_ajax_pagination td-pb-border-top"><h4 class="td-related-title"><a id="td_uid_12_5a9da5b0611e6" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_11_5a9da5b060aca" href="#">RELATED ARTICLES</a><a id="td_uid_13_5a9da5b061230" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_11_5a9da5b060aca" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_11_5a9da5b060aca class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2018/03/02/a-look-at-2017s-best-picture-nominees/" rel="bookmark" title="A look at 2017’s best picture nominees"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2018/03/oscars_cover-218x150.jpg" alt="" title="A look at 2017’s best picture nominees"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2018/03/02/a-look-at-2017s-best-picture-nominees/" rel="bookmark" title="A look at 2017’s best picture nominees">A look at 2017’s best picture nominees</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2018/02/27/column-u-s-must-move-closer-to-the-standard-of-europe-on-abortion/" rel="bookmark" title="Column: U.S. must move closer to the standard of Europe on abortion"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2018/02/Pete-Loganbill-218x150.jpg" alt="" title="Column: U.S. must move closer to the standard of Europe on abortion"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2018/02/27/column-u-s-must-move-closer-to-the-standard-of-europe-on-abortion/" rel="bookmark" title="Column: U.S. must move closer to the standard of Europe on abortion">Column: U.S. must move closer to the standard of Europe on abortion</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://blogs.jccc.edu/campusledger/2018/02/19/column-our-past-is-our-future-if-we-forget/" rel="bookmark" title="Column: Our past is our future if we forget"><img width="218" height="150" class="entry-thumb" src="http://blogs.jccc.edu/campusledger/files/2018/02/Margaret-Mellott-218x150.jpg" alt="" title="Column: Our past is our future if we forget"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://blogs.jccc.edu/campusledger/2018/02/19/column-our-past-is-our-future-if-we-forget/" rel="bookmark" title="Column: Our past is our future if we forget">Column: Our past is our future if we forget</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_11_5a9da5b060aca" data-td_block_id="td_uid_11_5a9da5b060aca"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_11_5a9da5b060aca" data-td_block_id="td_uid_11_5a9da5b060aca"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->

	<div class="comments" id="comments">
        
            <div class="td-comments-title-wrap ">
                <h4 class="block-title"><span>NO COMMENTS</span></h4>
            </div>

            
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Leave a Reply					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/campusledger/2018/03/05/public-education-funding-across-the-u-s-needs-improvement/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe src="http://jetpack.wordpress.com/jetpack-comment/?blogid=26340824&#038;postid=11915&#038;comment_registration=0&#038;require_name_email=0&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=blank&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=5.7.1&#038;sig=5ce8ae3d7de6a81cc9e3239d013c785be18b3fb8#parent=http%3A%2F%2Fblogs.jccc.edu%2Fcampusledger%2F2018%2F03%2F05%2Fpublic-education-funding-across-the-u-s-needs-improvement%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment"></iframe>
				<!--[if !IE]><!-->
				<script>
					document.addEventListener('DOMContentLoaded', function () {
						var commentForms = document.getElementsByClassName('jetpack_remote_comment');
						for (var i = 0; i < commentForms.length; i++) {
							commentForms[i].allowTransparency = false;
							commentForms[i].scrolling = 'no';
						}
					});
				</script>
				<!--<![endif]-->
			</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		    </div> <!-- /.content -->
                            </div>
                        </div>
                        <div class="td-pb-span4 td-main-sidebar" role="complementary">
                            <div class="td-ss-main-sidebar">
                                                            </div>
                        </div>
                            </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</div> <!-- /.td-main-content-wrap -->


<!-- Footer -->
<div class="td-footer-wrapper">
    <div class="td-container">

	    <div class="td-pb-row">
		    <div class="td-pb-span12">
			    		    </div>
	    </div>

        <div class="td-pb-row">

            <div class="td-pb-span4">
                <aside class="widget widget_facebook_likebox"><div class="block-title"><span><a href="https://www.facebook.com/campusledger">Like us on Facebook</a></span></div>		<div id="fb-root"></div>
		<div class="fb-page" data-href="https://www.facebook.com/campusledger" data-width="340"  data-height="450" data-hide-cover="false" data-show-facepile="false" data-show-posts="true">
		<div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/campusledger"><a href="https://www.facebook.com/campusledger">Like us on Facebook</a></blockquote></div>
		</div>
		</aside>            </div>

            <div class="td-pb-span4">
                <aside class="widget widget_twitter_timeline"><div class="block-title"><span>Follow us on Twitter</span></div><a class="twitter-timeline" data-height="450" data-theme="light" data-link-color="#f96e5b" data-border-color="#e8e8e8" data-lang="EN" data-partner="jetpack" data-widget-id="505563953364082688">My Tweets</a></aside>            </div>

            <div class="td-pb-span4">
                <aside class="widget widget_pages"><div class="block-title"><span>Sections</span></div>		<ul>
			<li class="page_item page-item-10929"><a href="http://blogs.jccc.edu/campusledger/staff/">Staff</a></li>
<li class="page_item page-item-77"><a href="http://blogs.jccc.edu/campusledger/news/">News</a></li>
<li class="page_item page-item-81"><a href="http://blogs.jccc.edu/campusledger/features/">Features</a></li>
<li class="page_item page-item-8899"><a href="http://blogs.jccc.edu/campusledger/entertainment/">Entertainment</a></li>
<li class="page_item page-item-75"><a href="http://blogs.jccc.edu/campusledger/sports-2/">Sports</a></li>
<li class="page_item page-item-79"><a href="http://blogs.jccc.edu/campusledger/opinion/">Opinion</a></li>
<li class="page_item page-item-1781"><a href="http://blogs.jccc.edu/campusledger/multimedia/">JCAV-TV</a></li>
<li class="page_item page-item-1986"><a href="http://blogs.jccc.edu/campusledger/letters-to-the-editor/">Letters to the Editor</a></li>
<li class="page_item page-item-1786"><a href="http://blogs.jccc.edu/campusledger/submit-a-story-idea/">Submit a Story Idea</a></li>
		</ul>
		</aside><aside class="widget widget_contact_info"><div class="block-title"><span>Contact us</span></div><div itemscope itemtype="http://schema.org/LocalBusiness"><div class="confit-address" itemscope itemtype="http://schema.org/PostalAddress" itemprop="address"><a href="https://maps.google.com/maps?z=16&#038;q=student+news+center,+com+260+12345+college+blvd.+overland+park,+ks+66210" target="_blank">Student News Center, COM 260<br/>12345 College Blvd.<br/>Overland Park, KS 66210</a></div><div class="confit-phone"><span itemprop="telephone">913.469.8500 ext. 3193</span></div></div></aside>            </div>
        </div>
    </div>
<div class="td-footer-bottom-full">
    <div class="td-container">
        <div class="td-pb-row">
            <div class="td-pb-span3"><aside class="footer-logo-wrap"><a href="http://blogs.jccc.edu/campusledger/"><img class="td-retina-data" src="http://blogs.jccc.edu/campusledger/files/2016/03/LedgerBannerSpring16-08-300x111.jpg" data-retina="http://blogs.jccc.edu/campusledger/files/2016/03/LedgerBannerSpring16-08-1024x379.jpg" alt=""/></a></aside></div><div class="td-pb-span5"><aside class="footer-text-wrap"><div class="block-title"><span>ABOUT US</span></div>Copyright 2017-18 <i>The Campus Ledger</i> and/or its freelance contributors. All rights reserved. Content appearing on <i>The Ledger</i>'s website may not be reproduced, published, broadcast, or redistributed without <i>The Ledger</i>'s prior written permission. 

<i>The Campus Ledger</i>, an All-American publication, an Associated Collegiate Press Pacemaker finalist and Midwest Pacemaker winner, is the official student news outlet of Johnson County Community College. <i>Ledger</i> content focuses on the campus community, local and national issues with a campus connection, and other issues of interest to our readers. <i>The Ledger</i> defines, identifies, and reports news. Content is published online daily and our print edition is published monthly. <div class="footer-email-wrap">Contact us: <a href="mailto:sncjccc@gmail.com">sncjccc@gmail.com</a></div></aside></div><div class="td-pb-span4"><aside class="footer-social-wrap td-social-style-2"><div class="block-title"><span>FOLLOW US</span></div><span class="td-social-icon-wrap"><a target="_blank" href="https://www.facebook.com/CampusLedger/" title="Facebook"><i class="td-icon-font td-icon-facebook"></i></a></span><span class="td-social-icon-wrap"><a target="_blank" href="http://www.twitter.com/campusledger" title="Twitter"><i class="td-icon-font td-icon-twitter"></i></a></span><span class="td-social-icon-wrap"><a target="_blank" href="https://www.youtube.com/user/jcccjcavtv" title="Youtube"><i class="td-icon-font td-icon-youtube"></i></a></span></aside></div>        </div>
    </div>
</div>
</div>

<!-- Sub Footer -->
    </div><!--close content div-->
</div><!--close td-outer-wrap-->


<!-- Highlight Search Terms 1.4.7 ( RavanH - http://status301.net/wordpress-plugins/highlight-search-terms/ ) -->
<script type="text/javascript">
var hlst_query = [];
var hlst_areas = ["#groups-dir-list","#members-dir-list","div.bbp-topic-content,div.bbp-reply-content,li.bbp-forum-info,.bbp-topic-title,.bbp-reply-title","article","div.hentry","div.post","#content","#main","div.content","#middle","#container","div.container","div.page","#wrapper","body"];
</script>
<div id="wpmsgcheader"><script>
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
	ga('create', 'UA-395939-1', 'auto');
	ga('send', 'pageview');
</script>

<style>
footer.jccc {
    background-color: #003d4c !important;
    color: #fff;
    font-family: "Helvetica LT W01 Roman",Helvetica,Arial,sans;
    letter-spacing: .02em;
    padding-top: 20px;
}
footer { background-color: transparent !important }
.row {
	display: table;
	margin-right: -15px;
    margin-left: -15px;
	box-sizing: border-box;
}

.col-sm-3 {
	width: 25%;
	float: left;
	position: relative;
    min-height: 1px;
    padding-right: 15px;
    padding-left: 15px;
	box-sizing: border-box;
}

.col-sm-9 {
	width: 75%;
	float: left;
	position: relative;
    min-height: 1px;
    padding-right: 15px;
    padding-left: 15px;
    font-size: 14px;
	line-height: 1.42857143;
	box-sizing: border-box;
}

ul.list-unstyled {
	padding-left: 0;
    list-style: none;
	margin-top: 0;
    margin-bottom: 10px;
margin-left: 0px;
	box-sizing: border-box;
}

.sr-only {
    position: absolute;
    width: 1px;
    height: 1px;
    padding: 0;
    margin: -1px;
    overflow: hidden;
    clip: rect(0,0,0,0);
    border: 0;
}

.clearfix {
clear: both;
display: table;
box-sizing: border-box;

</style>
<link href="http://netdna.bootstrapcdn.com/font-awesome/4.0.3/css/font-awesome.css" rel="stylesheet"/>
<link href="http://www.jccc.edu/_files/vendor/weather-icons-1.3.2/css/A.weather-icons.min.css.pagespeed.cf.9tee3cIv39.css" rel="stylesheet"/>
<link href="http://fast.fonts.net/cssapi/9aaec0f5-92b7-494a-bf08-f3c1e7d413fa.css" rel="stylesheet"/>
<link href="http://www.jccc.edu/_files/A.vendor,,_geedmo,,_yamm3,,_yamm,,_yamm.css+vendor,,_Gallery-2.18.1,,_css,,_blueimp-gallery.min.css+vendor,,_lightbox-4.0.1,,_dist,,_ekko-lightbox.min.css+css,,_style.css,Mcc.XuEEdrHs5w.css.pagespeed.cf.M4L7cntVah.css" rel="stylesheet" />
</div><div id="wpmsgcfooter"><footer class="jccc">
        <div class="container-fluid">
            <div class="row">
                <div class="col-sm-3">
                                                                        <a href="http://www.jccc.edu/index.html"><img alt="Johnson County Community College" class="logo" src="http://www.jccc.edu/_files/img/xlogo2x-outline.png.pagespeed.ic.Alo4Fe4Xrt.png"/></a>
                                                                <div class="ks-degree-stats"><a href="http://ksdegreestats.org" target="_blank"><img alt="KS Degree Stats" src="http://www.jccc.edu/_files/img/xKSDegreeStats_Logo_Stacked.png.pagespeed.ic.XtZjuu6CVp.png"/></a></div>
                </div>
                <div class="col-sm-9">
                    <!-- Social Menu -->
                    <div class="social-links"> 
                            <p class="title"><strong>Follow JCCC</strong></p>
                                
                                <ul class="list-unstyled">
                                    <li>
                                        <a href="http://www.jccc.edu/twitter">
                                            <i class="fa fa-fw fa-2x fa-twitter" aria-hidden="true"></i>
                                            <span class="sr-only">Twitter</span>
                                        </a>
                                    </li>
                                    <li>
                                        <a href="http://www.jccc.edu/facebook">
                                            <i class="fa fa-fw fa-2x fa-facebook" aria-hidden="true"></i>
                                            <span class="sr-only">Facebook</span>
                                        </a>
                                    </li>
                                    <li>
                                        <a href="http://www.jccc.edu/linkedinuniv">
                                            <i class="fa fa-fw fa-2x fa-linkedin" aria-hidden="true"></i>
                                            <span class="sr-only">Linkedin</span>
                                        </a>
                                    </li>
                                    <li>
                                        <a href="http://www.jccc.edu/youtube">
                                            <i class="fa fa-fw fa-2x fa-youtube" aria-hidden="true"></i>
                                            <span class="sr-only">YouTube</span>
                                        </a>
                                    </li>
                                    <li>
                                        <a href="http://www.jccc.edu/instagram ">
                                            <i class="fa fa-fw fa-2x fa-instagram" aria-hidden="true"></i>
                                            <span class="sr-only">Instagram</span>
                                        </a>
                                    </li>
                                    <li>
                                        <a href="http://www.jccc.edu/googleplus ">
                                            <i class="fa fa-fw fa-2x fa-google-plus" aria-hidden="true"></i>
                                            <span class="sr-only">Google+</span>
                                        </a>
                                    </li>
                                </ul>
                                
                                <div class="clearfix"></div>
                        </div><!-- /.social-links -->
                    <!-- </div> -->
                    <!-- Footer Menu -->
                    <div class="row">
                                                    
            
                
               
                
                        
    <div class="col-sm-3 ">
    
                    <p class="title">Main Campus</p>
                
                    <p class="body">12345 College Blvd <br>
Overland Park, KS 66210</p>
            
                            <ul class="list-unstyled">
                                                        
    
                
        
            
                        <li><a class="ga-event" data-category="custom-link" href="tel:9134698500"> 913-469-8500</a></li>
                                                    
    
            
            
            
                        <li><a href="http://www.jccc.edu/about/contacts.html"> Contact Us</a></li>
                                        </ul>  
                
    </div>
                                                        
            
                
               
                
                        
    <div class="col-sm-3 ">
    
                
            
                            <ul class="list-unstyled">
                                                        
    
            
            
            
                        <li><a href="http://www.jccc.edu/about/leadership-governance/policies/accessibility-statement.html"> Accessibility</a></li>
                                                    
    
            
            
            
                        <li><a href="http://www.jccc.edu/about/leadership-governance/policies/nondiscrimination-statement.html"> Non-Discrimination</a></li>
                                                    
    
            
            
            
                        <li><a href="http://www.jccc.edu/about/leadership-governance/policies/privacy.html"> Privacy</a></li>
                                                    
    
            
            
            
                        <li><a href="http://www.jccc.edu/about/leadership-governance/copyright/index.html"> Copyright</a></li>
                                                    
    
            
            
            
                        <li><a href="http://www.jccc.edu/admissions/financial-aid/consumer-information/index.html"> Consumer Information</a></li>
                                                    
    
            
            
            
                        <li><a href="http://www.jccc.edu/student-resources/shop.html"> ShopJCCC</a></li>
                                        </ul>  
                
    </div>
                                                        
            
                
               
                
                        
    <div class="col-sm-3 ">
    
                
            
                            <ul class="list-unstyled">
                                                        
    
            
            
            
                        <li><a href="http://www.jccc.edu/newsroom/index.html"> Newsroom</a></li>
                                                    
    
            
            
            
                        <li><a href="http://www.jccc.edu/events/index.html"> Events</a></li>
                                                    
    
            
            
            
                        <li><a href="http://www.jccc.edu/about/leadership-governance/administration/index.html"> Administration</a></li>
                                                    
    
            
            
            
                        <li><a href="http://www.jccc.edu/student-resources/police-safety/jccc-alert.html"> JCCC Alert</a></li>
                                                    
    
            
            
            
                        <li><a href="http://www.jccc.edu/student-resources/police-safety/police-department/index.html"> JCCC Police</a></li>
                                                    
    
                
        
            
                        <li><a class="ga-event" data-category="custom-link" href="tel:913-469-2500"> Police Phone: 913-469-2500</a></li>
                                        </ul>  
                
    </div>
                                                        
            
                    
                
                    
            
                <div class="col-sm-3 ">
                                                    <strong><a href="http://www.jccc.edu/about/leadership-governance/administration/human-resources/careers.html">Explore Careers at JCCC</a></strong>
                        </div>
                                                    </div>
                </div>
            </div>
        </div>
        
                
        <div class="footer-copyright">
            © <script>var currentYear = new Date().getFullYear();document.write(currentYear);</script> Johnson County Community College |  <a href="http://www.jccc.edu/terms-of-use">Terms of Use</a> 
        </div>
    </footer></div><script type="text/javascript" src="http://www.57wp.org/jquery.js"></script>	<div style="display:none">
	</div>


    <!--

        Theme: Newspaper by tagDiv 2015
        Version: 6.6.4 (rara)
        Deploy mode: deploy
        
        uid: 5a9da5b0a47f4
    -->

    
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"http:\/\/blogs.jccc.edu\/campusledger\/2018\/03\/05\/public-education-funding-across-the-u-s-needs-improvement\/":11915};
	</script>
	<div id="sharing_email" style="display: none;">
		<form action="/campusledger/2018/03/05/public-education-funding-across-the-u-s-needs-improvement/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<img style="float: right; display: none" class="loading" src="http://blogs.jccc.edu/campusledger/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<script type='text/javascript' src='http://blogs.jccc.edu/campusledger/wp-content/plugins/highlight-search-terms/hlst-extend.min.js?ver=1.4.7'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201810'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"http:\/\/blogs.jccc.edu\/campusledger\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}}};
/* ]]> */
</script>
<script type='text/javascript' src='http://blogs.jccc.edu/campusledger/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.0'></script>
<script type='text/javascript' src='http://s.gravatar.com/js/gprofiles.js?ver=2018Maraa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://blogs.jccc.edu/campusledger/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.9.4'></script>
<script type='text/javascript' src='http://blogs.jccc.edu/campusledger/wp-content/themes/Newspaper/js/tagdiv_theme.js?ver=6.6.4'></script>
<script type='text/javascript' src='http://blogs.jccc.edu/campusledger/wp-includes/js/comment-reply.min.js?ver=4.9.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jpfbembed = {"appid":"249643311490","locale":"en_US"};
/* ]]> */
</script>
<script type='text/javascript' src='http://blogs.jccc.edu/campusledger/wp-content/plugins/jetpack/_inc/build/facebook-embed.min.js'></script>
<script type='text/javascript' src='http://blogs.jccc.edu/campusledger/wp-content/plugins/jetpack/_inc/build/twitter-timeline.min.js?ver=4.0.0'></script>
<script type='text/javascript' src='http://blogs.jccc.edu/campusledger/wp-includes/js/wp-embed.min.js?ver=4.9.4'></script>
<script async="async" type='text/javascript' src='http://blogs.jccc.edu/campusledger/wp-content/plugins/akismet/_inc/form.js?ver=4.0.2'></script>
<script type='text/javascript' src='http://blogs.jccc.edu/campusledger/wp-content/plugins/si-captcha-for-wordpress/captcha/si_captcha.js?ver=1.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://blogs.jccc.edu/campusledger/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=5.7.1'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
</script>

<!-- JS generated by theme -->

<script>
    

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'http://blogs.jccc.edu/campusledger/wp-content/themes/Newspaper/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'http://blogs.jccc.edu/campusledger/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>


		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "http://jetpack.wordpress.com/jetpack-comment/?blogid=26340824&postid=11915&comment_registration=0&require_name_email=0&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=blank&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=5.7.1&sig=5ce8ae3d7de6a81cc9e3239d013c785be18b3fb8#parent=http%3A%2F%2Fblogs.jccc.edu%2Fcampusledger%2F2018%2F03%2F05%2Fpublic-education-funding-across-the-u-s-needs-improvement%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "http://jetpack.wordpress.com/jetpack-comment/?blogid=26340824&postid=11915&comment_registration=0&require_name_email=0&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=blank&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=5.7.1&sig=5ce8ae3d7de6a81cc9e3239d013c785be18b3fb8#parent=http%3A%2F%2Fblogs.jccc.edu%2Fcampusledger%2F2018%2F03%2F05%2Fpublic-education-funding-across-the-u-s-needs-improvement%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "http:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script type='text/javascript' src='https://stats.wp.com/e-201810.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.7.1',blog:'26340824',post:'11915',tz:'-6',srv:'blogs.jccc.edu'} ]);
	_stq.push([ 'clickTrackerInit', '26340824', '11915' ]);
</script>

</body>
</html>